Bug 125652 - installer can use eth0 but not eth2 (all adapters are Broadcomm)
installer can use eth0 but not eth2 (all adapters are Broadcomm)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 13:56 EDT by Patrick C. F. Ernzer
Modified: 2013-07-02 22:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 02:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2004-06-09 13:56:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
(all this is from memory, I am currently in my hotel. I could not file
earlier as I was stuck in a server room without external connectivity)

When trying to kickstart an IBM x445 with 4 Broadcomm network
adapters, I am able to use eth0 as ksdevice, but not eth2.

Customer tells me they were unable to use eth2 with RHEL 3 U1 but that
the problem went away on a subsequent up2date run. (Their machine has
no problem using eth2 under kernel 2.4.21-15.EL, which is weird
because kernel-BOOT-2.4.21-15.EL exhibits the problem descibed below.)

Version-Release number of selected component (if applicable):
kernel-BOOT-2.4.21-15.EL

How reproducible:
Always

Steps to Reproduce:
1. Boot the RHEL 3 U2 i386 kernel and initrd via pxe
2. attempt a kickstart install with ksdevice=eth2
3. DHCP address is assigned fine at boot time, but only then
    

Actual Results:  When the kernel has booted and the installer tries to
get an IP address via DHCP, it times out.

The DHCP server sees no request coming in.

I did verify that eth2 is what I expect (i.e. the MAC address is the
right one), I did also verify that the booted kernel is indeed
2.4.21-15.ELBOOT

Setting an IP address by hand (when anaconda prompts me to do so) does
not help either, the interface is reported as up but I am both unable
to ping another machine.Trying to ping the machine from an external
box is not possible either (host unreachable)

arp shows me entries with 'incomplete', ther eis not a singe good entry.

setting the arp entries by hand does not help either.

Expected Results:  being able to kickstart over eth2

Additional info:

switching the cables in eth0 and eth2, followed by using ksdevice=eth0
works just like expected.

The problem is that customer will have to rewire 30+ machines and
update all documentation (MAC addresses are documented here).

I'll get customer to subscribe to this bug as I am only on-site for
one more day.

It would be really nice if we could give an estimate on how long this
may take to fix so that customer can decide between rewiring and waiting.
Comment 1 Jeff Garzik 2005-02-18 02:14:57 EST
tg3 updates should have fixed this?

Note You need to log in before you can comment on or make changes to this bug.