Bug 1256538 - rhel-osp-director: "openstack overcloud update stack --templates -e <yaml> -i overcloud" is running for a long time although the yum repos aren't avilable. [NEEDINFO]
rhel-osp-director: "openstack overcloud update stack --templates -e <yaml> -...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
unspecified
x86_64 Linux
high Severity medium
: z3
: 7.0 (Kilo)
Assigned To: Zane Bitter
Amit Ugol
: Triaged, ZStream
Depends On: 1257717 1265010
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 17:23 EDT by Alexander Chuzhoy
Modified: 2016-04-26 22:19 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:01:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jprovazn: needinfo? (sasha)


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-08-24 17:23:01 EDT
rhel-osp-director: "openstack overcloud update stack --templates  -e <yaml> -i overcloud" is running for a long time although the yum repos aren't avilable.


Environment:
instack-undercloud-2.1.2-23.el7ost.noarch

Steps to reproduce:
1. Deploy an overcloud registered with RHN
openstack overcloud deploy --templates --control-scale 1 --compute-scale 1 --ceph-storage-scale 1 -e <yaml> --ntp-server <IP>  --timeout 90 --compute-flavor compute --control-flavor control --ceph-storage-flavor ceph --rhel-reg --reg-method portal --reg-org <ID>  --reg-activation-key 'key'

2. Attempt to update the stack:
openstack overcloud update stack --templates  -e <yaml> -i overcloud

Note: yum repolist on 2 hosts out of 3 shows an empty list after the update started. The repos were there before attempting the update. 


Result:
The update process doesn't end for a long time, keeps on generating "IN_PROGRESS" lines. 
Manually fixed the repos on the 2 remaining nodes. The update doesn't seem to start on them, although the "IN_PROGRESS" lines are still being generated.
No "yum" process on the nodes.

Expected result:
The update process should end with error due to the missing repos to get the updates from.
Comment 4 Jan Provaznik 2015-09-04 01:54:01 EDT
This is probably caused by the same issue as described in https://bugzilla.redhat.com/show_bug.cgi?id=1255931#c5, if so it should be fixed by the https://bugzilla.redhat.com/show_bug.cgi?id=1257717

Please check if the issue remains with the patch for 1257717.

Depends On: 1257717
Comment 8 Amit Ugol 2015-11-23 11:08:06 EST
This depends on other bugs that are already closed in errata
Comment 10 errata-xmlrpc 2015-12-21 12:01:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2680

Note You need to log in before you can comment on or make changes to this bug.