Bug 1256583 - Win10 guest can't get ip address from dhcpserver when add mrg_rxbuf=off for virtio-net-pci
Summary: Win10 guest can't get ip address from dhcpserver when add mrg_rxbuf=off for v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-25 04:07 UTC by weliao
Modified: 2016-11-04 08:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:49:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description weliao 2015-08-25 04:07:23 UTC
Description of problem:
Use virtio-win : virtio-win-prewhql-0.1-109,when add mrg_rxbuf=off for virtio-net-pci,can't get ip address from dhcpserver, 105 no this issue 

Version-Release number of selected component (if applicable):
3.10.0-305.el7.x86_64
qemu-kvm-1.5.3-101.el7.x86_64
virtio-win-prewhql-0.1-109

How reproducible:
100%

Steps to Reproduce:
1.Boot win10 guest whit mrg_rxbuf=off
-netdev tap,id=hostnet0,vhost=on,vhostforce=off \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:83:66:77:88:66,bus=pci.0,addr=0x3,status=on,mrg_rxbuf=off


Actual results:
 can't get ip address from dhcpserver

Expected results:
 can get ip address from dhcpserver

Additional info:
/usr/libexec/qemu-kvm -name win10qcow2 -M pc-i440fx-rhel7.0.0 -cpu SandyBridge -m 4096 -realtime mlock=off -smp 4,sockets=1,cores=4 \
-device virtio-scsi-pci,id=scsi2,indirect_desc=off,event_idx=off,bus=pci.0 -drive file=/mnt/win10.qcow2.1,if=none,id=drive-scsi-disk0,format=qcow2 \
-device scsi-hd,bus=scsi2.0,drive=drive-scsi-disk0,id=scsi-disk0 \
-boot menu=on \
-netdev tap,id=hostnet0,vhost=on,vhostforce=off \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:83:66:77:88:66,bus=pci.0,addr=0x3,status=on,mrg_rxbuf=off \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x5 \
-spice port=6800,disable-ticketing, -monitor stdio -qmp tcp:0:4444,server,nowait

Comment 5 wehao 2016-01-06 07:45:38 UTC
Reproduced this issue on virtio-win-prewhql-0.1-109 version
Verified this issue on virtio-win-prewhql-0.1-112 version

Steps same as comment#0

Actual Results:
on virtio-win-prewhql-0.1-109 (un-fixed) version,can't get ip address from dhcpserver
on virtio-win-prewhql-0.1-112 fix version, can get ip address from dhcpserver

Base on above, this issue has been fixed already.

Comment 6 lijin 2016-01-06 08:21:50 UTC
change status to verified according to comment#5

Comment 9 errata-xmlrpc 2016-11-04 08:49:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.