Bug 1256591 - Data Tiering: Database locks observed on tiered volumes on continous writes to a file
Data Tiering: Database locks observed on tiered volumes on continous writes t...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glusterfs (Show other bugs)
6.8
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jan Staněk
Anoop
: Reopened
Depends On:
Blocks: 1240569
  Show dependency treegraph
 
Reported: 2015-08-25 01:12 EDT by Vivek Agarwal
Modified: 2016-02-17 19:03 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240569
Environment:
Last Closed: 2015-09-23 09:19:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Rejy M Cyriac 2015-08-28 10:39:50 EDT
The WAL journaling mode does not work in sqlite 3.6.20-1 available at RHEL 6. 

WAL Journaling mode is absolutely required for the Data Tiering feature of Red Hat Gluster Storage on RHEL 6

It is required to upgrade sqlite version on RHEL 6.7 to sqlite 3.7 and above, which supports WAL journaling mode
Comment 3 Dan Lambright 2015-09-22 16:06:26 EDT

*** This bug has been marked as a duplicate of bug 1265399 ***
Comment 4 Rejy M Cyriac 2015-09-23 00:13:03 EDT
(In reply to Dan Lambright from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 1265399 ***

Why was this BZ on RHEL6 closed as a DUPLICATE of an upstream bug?!

Re-opening this BZ, and changing the summary to reflect the objective of this BZ on RHEL6
Comment 5 Dan Lambright 2015-09-23 09:19:24 EDT
We have a a software workaround for this problem described in 1265399. It solves the data base lock problem, but because it still uses the old sqlite without WAL, performance is poor. Also, my understanding is we will not be able to get the newer sqlite on RHEL6 in any circumstances. If you know differently, Mr Cyriac, I would be greatly interested in hearing that. This bug should not be the NEW state. I would say it is resolved as WONTFIX if its not a duplicate.

Note You need to log in before you can comment on or make changes to this bug.