Bug 1256612 - Can not create app/add cartridge successfully on STG sometimes
Can not create app/add cartridge successfully on STG sometimes
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 02:42 EDT by Yan Du
Modified: 2017-05-31 14:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2015-08-25 02:42:41 EDT
Description of problem:
when testing automation, there are about 20-25 concurrent requests sending at the same time, some operation could not be successful, eg: create app, scale up app and add cartriage to app etc, we got some error as below:

1. 
# rhc app create tfc1uitl python-2.7 mongodb-2.4 -s -g small --namespace  gucscy --rhlogin libra-test+power7@redhat.com --server  stg.openshift.redhat.com
Application Options 
------------------- 
Domain:     gucscy 
Cartridges: python-2.7, mongodb-2.4 
Gear Size:  small 
Scaling:    yes 

Creating application 'tfc1uitl' ... Server returned an unexpected error code: 504 
05:21:44 INFO> Exit Status: 1
05:21:44 WARN> Expected response not found: Your application 'tfc1uitl' is now available
05:21:44  WARN> Failed to get the following properties: url, git_url, ssh_url,  username, password, repo, dashboard_admin, dashboard_admin_password,  teliid_user, teliid_password, modeshape_user, modeshape_user_password,  modeshape_admin, modeshape_admin_password in the output of rhc client

2. 
#rhc cartridge add -a dbscale1 mysql-5.1 --rhlogin libra-test+power12@redhat.com  --server stg.openshift.redhat.com
Adding mysql-5.1 to application 'dbscale1' ... Server returned an unexpected error code: 504 


3. 
# rhc cartridge add -a dbscale1 mysql-5.1 --rhlogin libra-test+power18@redhat.com  --server stg.openshift.redhat.com
Adding mysql-5.1 to  application 'dbscale1' ... An error occurred while communicating with  the server. This problem may only be temporary. Check that you have  correctly specified your OpenShift server  'https://stg.openshift.redhat.com/broker/rest/application/55dbfaeac0c5a77d8f000254/cartridges'.


4.
Creating application 'zrgnzyhu' ... Unable to complete the requested operation due to: The server ex-std-node1.stg.rhcloud.com that your application is running on failed to respond in time. This may be due to a system restart.
Reference ID: 0296d408de04ef1fa0e4631e9bf62227


Version-Release number of selected component (if applicable):
STG(devenv_stage_1177)


How reproducible:
50%

Steps to Reproduce:
1. Create a bunch of apps and do some operation like scale app or add db to app


Actual results:
Same as description

Expected results:
All the operation could be successful without error.


Additional info:
Comment 1 Abhishek Gupta 2015-09-25 14:26:33 EDT
I believe this was an issue with the proxy configuration in STG where 503s were being returned. As of now, the number of calls resulting in 503s has been reduced greatly and these requests/tests do pass on subsequent attempts.
Comment 2 Yan Du 2015-10-27 04:30:27 EDT
Test on STG(devenv-stage_1188)

Issue could not be reproduced. Move bug to verified.
Comment 3 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.