This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256644 - [abrt] gnome-tweak-tool: g_settings_set_property(): python2.7 killed by SIGTRAP
[abrt] gnome-tweak-tool: g_settings_set_property(): python2.7 killed by SIGTRAP
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-tweak-tool (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rui Matos
Desktop QE
abrt_hash:2b30fd9a13b155086ed1b94dc2f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 03:29 EDT by Ondrej Hudlicky
Modified: 2015-11-19 02:34 EST (History)
4 users (show)

See Also:
Fixed In Version: gnome-tweak-tool-3.14.3-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:34:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.47 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: cgroup (181 bytes, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: core_backtrace (28.72 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: dso_list (12.50 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: environ (1.60 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: machineid (135 bytes, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: maps (61.38 KB, text/plain)
2015-08-25 03:29 EDT, Ondrej Hudlicky
no flags Details
File: open_fds (721 bytes, text/plain)
2015-08-25 03:30 EDT, Ondrej Hudlicky
no flags Details
File: proc_pid_status (1.07 KB, text/plain)
2015-08-25 03:30 EDT, Ondrej Hudlicky
no flags Details

  None (edit)
Description Ondrej Hudlicky 2015-08-25 03:29:47 EDT
Description of problem:
1. yum remove  gnome-classic-session 
2. gnome-tweak-tool 
(gnome-tweak-tool:29876): GLib-GIO-ERROR **: Settings schema 'org.gnome.shell.extensions.classic-overrides' is not installed
Trace/breakpoint trap (core dumped)

Version-Release number of selected component:
gnome-tweak-tool-3.14.3-1.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/gnome-tweak-tool
crash_function: g_settings_set_property
executable:     /usr/bin/python2.7
kernel:         3.10.0-306.0.1.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_settings_set_property at /lib64/libgio-2.0.so.0
 #3 g_object_new_internal at /lib64/libgobject-2.0.so.0
 #5 pygobject_constructv at /usr/lib64/python2.7/site-packages/gi/_gi.so
 #6 pygobject_init at /usr/lib64/python2.7/site-packages/gi/_gi.so
 #7 wrap_init at /lib64/libpython2.7.so.1.0
 #8 PyObject_Call at /lib64/libpython2.7.so.1.0
 #9 PyEval_CallObjectWithKeywords at /lib64/libpython2.7.so.1.0
 #10 wrapperdescr_call at /lib64/libpython2.7.so.1.0
 #11 PyObject_Call at /lib64/libpython2.7.so.1.0
 #12 PyEval_EvalFrameEx at /lib64/libpython2.7.so.1.0
Comment 1 Ondrej Hudlicky 2015-08-25 03:29:49 EDT
Created attachment 1066758 [details]
File: backtrace
Comment 2 Ondrej Hudlicky 2015-08-25 03:29:51 EDT
Created attachment 1066759 [details]
File: cgroup
Comment 3 Ondrej Hudlicky 2015-08-25 03:29:52 EDT
Created attachment 1066760 [details]
File: core_backtrace
Comment 4 Ondrej Hudlicky 2015-08-25 03:29:54 EDT
Created attachment 1066761 [details]
File: dso_list
Comment 5 Ondrej Hudlicky 2015-08-25 03:29:55 EDT
Created attachment 1066762 [details]
File: environ
Comment 6 Ondrej Hudlicky 2015-08-25 03:29:56 EDT
Created attachment 1066763 [details]
File: limits
Comment 7 Ondrej Hudlicky 2015-08-25 03:29:57 EDT
Created attachment 1066764 [details]
File: machineid
Comment 8 Ondrej Hudlicky 2015-08-25 03:29:59 EDT
Created attachment 1066765 [details]
File: maps
Comment 9 Ondrej Hudlicky 2015-08-25 03:30:00 EDT
Created attachment 1066766 [details]
File: open_fds
Comment 10 Ondrej Hudlicky 2015-08-25 03:30:01 EDT
Created attachment 1066767 [details]
File: proc_pid_status
Comment 12 Rui Matos 2015-08-25 08:41:10 EDT
Do you have the package gnome-classic-session installed?
Comment 13 Ondrej Hudlicky 2015-08-25 12:42:11 EDT
Crashed only when gnome-classic-session is uninstalled. 
I remove the rpm during attempt to remove a broken extension - see bug 1256647

Still this is a bug - crash is incorrect behaviour - shouldn't be the gnome-classic-session a dependency of gnome-tweak-tool in RHEL7?
Comment 14 Rui Matos 2015-08-26 11:18:38 EDT
(In reply to Ondrej Hudlicky from comment #13)
> Still this is a bug - crash is incorrect behaviour - shouldn't be the
> gnome-classic-session a dependency of gnome-tweak-tool in RHEL7?

g-t-t would have to depend on almost all desktop rpms, so no. But we can avoid the crash, sure.

Will need the QA ack
Comment 17 errata-xmlrpc 2015-11-19 02:34:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2215.html

Note You need to log in before you can comment on or make changes to this bug.