Bug 1256683 - UI not show all "Run on" hosts under vm general tab
UI not show all "Run on" hosts under vm general tab
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
All Linux
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Greg Sheremeta
movciari
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:21 EDT by Artyom
Modified: 2016-03-16 15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-16 15:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
screenshots (123.00 KB, application/x-gzip)
2015-08-25 05:21 EDT, Artyom
no flags Details
VMs General Sub Tab - Run On - Improvement Suggestion (89.51 KB, image/png)
2015-08-26 12:33 EDT, Einav Cohen
no flags Details
run on wraps (12.89 KB, image/png)
2016-03-16 15:05 EDT, Greg Sheremeta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45730 master MERGED frontend: Show all pinned hosts in general model forms Never
oVirt gerrit 45849 ovirt-engine-3.6 MERGED frontend: Show all pinned hosts in general model forms Never
oVirt gerrit 46469 master DRAFT portal: Use patternfly Tooltip to show too long host names Never

  None (edit)
Description Artyom 2015-08-25 05:21:55 EDT
Created attachment 1066792 [details]
screenshots

Description of problem:
UI not show all vm "Run on" hosts under vm general tab

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0-0.12.master.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create vm and pin it two hosts
2. Check vm->General Tab->Run on field 
3.

Actual results:
Show only one host

Expected results:
Must show two hosts

Additional info:
See screenshot for more details
Comment 1 Doron Fediuck 2015-08-26 09:13:51 EDT
Einav we may need some advice here on how to present the information without
overloading the text field.
Comment 2 Einav Cohen 2015-08-26 12:33:41 EDT
Created attachment 1067353 [details]
VMs General Sub Tab - Run On - Improvement Suggestion
Comment 3 Einav Cohen 2015-08-26 12:39:31 EDT
We can do one of two things:

(1) simply have a comma-separated list as the value and have it cropped if it is too long, and wait for bug 1205309 to be resolved in order to support displaying cropped values in a tool-tip upon hover. 

(2) do something similar to the 'Attached To' column in the Disks main tab [see http://i.imgur.com/Yd0iXQj.png] - display the Host Name if there is a single Host, and display "x Hosts" and the Host-Names in a tool-tip upon hover if there is more than one Host (see attachment 1067353 [details]). 
[this may still depend on bug 1205309, since I am not sure if ATM we have no tool-tips support in the General sub-tabs at all, or if we don't have tool-tips support in General sub-tabs only for cropped values - CC'ing Greg that may have additional insights]
Comment 4 Greg Sheremeta 2015-08-26 17:23:24 EDT
You can make tooltips on anything now. They're free in grids, and otherwise as simple as new WidgetTooltip("Hello there!")
Comment 5 Roman Mohr 2015-09-03 11:26:36 EDT
I implementet solutio(In reply to Einav Cohen from comment #3)
> We can do one of two things:
> 
> (1) simply have a comma-separated list as the value and have it cropped if
> it is too long, and wait for bug 1205309 to be resolved in order to support
> displaying cropped values in a tool-tip upon hover. 

Implemented this solution with the comma separated list and a tool-tip. It was as easy as setting the title of of the TextBoxLabel
Comment 6 Roman Mohr 2015-09-03 11:28:26 EDT
The bug also affected the general tab of the pools in the admin portal and the VM and pool tab in the user portal.
Comment 7 Sandro Bonazzola 2015-09-17 03:21:50 EDT
3.6.1 has not yet been released, resetting version.
Please fix it to the version where this bug was discovered.
Comment 10 Greg Sheremeta 2015-09-17 08:24:55 EDT
Putting the bug back to assigned. The tooltips need to be implemented with PatternFly -- we are no longer using setTitle() for tooltips.
Comment 11 Sandro Bonazzola 2015-10-26 08:33:10 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 12 Roman Mohr 2015-10-29 09:54:47 EDT
I think this can go to 4.0.0 especially since the described problem is fixed. The tooltip is just displayed in a deprecated way.

@Grep assigning you the bug since you wanted to do some extra changes to the tooltip internals.
Comment 13 Greg Sheremeta 2016-03-16 15:04:56 EDT
Roman fixed this already (comment 12).

The bug was only open until we got the long-value wrapping done, and that is also now fixed (see attached screenshot).

Closing.
Comment 14 Greg Sheremeta 2016-03-16 15:05 EDT
Created attachment 1137140 [details]
run on wraps

Note You need to log in before you can comment on or make changes to this bug.