Bug 1256687 - [RFE]Can't see any snapshots in RHEVM when converted guest from local kvm
[RFE]Can't see any snapshots in RHEVM when converted guest from local kvm
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
V2V
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:28 EDT by xiaodwan
Modified: 2015-09-01 04:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 02:50:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of snapshots (166.27 KB, image/png)
2015-08-25 05:29 EDT, xiaodwan
no flags Details

  None (edit)
Description xiaodwan 2015-08-25 05:28:18 EDT
Description of problem:
[RFE]Can't see any snapshots in RHEVM when converted guest from local kvm

Version-Release number of selected component (if applicable):
virt-v2v-1.28.1-1.49.el7.x86_64
qemu-kvm-rhev-2.3.0-18.el7.x86_64
libvirt-1.2.17-6.el7.x86_64
libguestfs-1.28.1-1.49.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make snapshots for the VM:virsh snapshot-create <domain-name>
2. Convert and imported it to 'Virtual Machine' tab. 
# virt-v2v -o rhev -os 10.66.90.115:/vol/v2v_auto/nfs_export -n rhevm rhel7.1
3. In RHEVM->'Virtual Machines' tab,the VM you conveted and imported will be listed there
4. Select the VM, Go to "Snapshots" tab, Check the Snapshots.

Actual results:
No snapshots list in RHEVM->"Virtual Machines"-> "Snapshots".

Expected results:
The snapshot should list in RHEVM->"Virtual Machines"-> "Snapshots"

Additional info:
Comment 2 xiaodwan 2015-08-25 05:29:46 EDT
Created attachment 1066795 [details]
screenshot of snapshots
Comment 3 Richard W.M. Jones 2015-08-28 14:35:40 EDT
Basically virt-v2v doesn't support conversion of snapshots.
Same applies to VMware conversions.
Comment 4 Richard W.M. Jones 2015-09-01 02:50:09 EDT
Closing this as NOTABUG because we don't support conversion of
snapshots and never did.
Comment 5 xiaodwan 2015-09-01 04:03:03 EDT
(In reply to Richard W.M. Jones from comment #4)
> Closing this as NOTABUG because we don't support conversion of
> snapshots and never did.

hi Richard, 

since we don't have plan to support conversion of snapshots, could you update the status to WONt FIX? I think it's better than NOTABUG for this issue. 

Thanks
Comment 6 Richard W.M. Jones 2015-09-01 04:07:45 EDT
Correct yes .. NOTABUG -> WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.