Bug 1256696 - efl-devel obsoletes e_dbus
efl-devel obsoletes e_dbus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: moksha (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:35 EDT by L.L.Robinson
Modified: 2016-09-19 22:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 02:25:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L.L.Robinson 2015-08-25 05:35:34 EDT
Description of problem:
I'm trying to build Moksha, a fork of e17. It requires e_dbus-devel and efreet-devel 1.7.10. However if I try to package the requirements mock always replaces these packages with efl-devel. the build then fails because Moksha cannot find the edbus package. the build suceeds if I manualy build using 
e_dbus

Version-Release number of selected component (if applicable): 1.4


How reproducible:Alsways


Steps to Reproduce:
1.Spec File and srpm http://therobinsonfamily.net/SPECS/moksha.spec  https://therobinsonfamily.net/SRPMS/moksha-0.1.0-1.fc22.src.rpm
2.build using mock
3.

Actual results:
build fails sue to elf-devel obsoleteing e_dbus-devel and eftreet-devel

Expected results:
build

Additional info:
Comment 1 Tom "spot" Callaway 2015-08-25 10:47:56 EDT
Hm. The problem is that if you're not using Moksha, e_dbus never gets cleaned up upgrading from e17 to e19.

Can I suggest that you instead make a moksha-e_dbus & moksha-efreet package that has e_dbus inside of it? Then you can dep on moksha-e_dbus-devel && moksha-efreet-devel and not have any conflicts with the Provides/Obsoletes in efl.

(You might be able to use the libefreet.so.1 in efl, not sure though.)
Comment 2 L.L.Robinson 2015-08-26 06:05:04 EDT
Works a treat. Can now compile Moksha with no errors, for reference the spec file is available here:  http://therobinsonfamily.net/SPECS/moksha-e_dbus.spec
Comment 3 Fedora Update System 2016-01-04 22:10:37 EST
efl-1.16.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f59767cd5d
Comment 4 Fedora Update System 2016-01-05 18:26:41 EST
efl-1.16.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f59767cd5d
Comment 5 Ding-Yi Chen 2016-01-21 02:35:53 EST
This looks more like an moksha instead of efl
Comment 6 Fedora Update System 2016-01-22 02:25:44 EST
efl-1.16.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.