Bug 1256698 - unhandled Python exception in '/usr/libexec/ipa/com.redhat.idm.trust-fetch-domains'
unhandled Python exception in '/usr/libexec/ipa/com.redhat.idm.trust-fetch-do...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:45 EDT by Sudhir Menon
Modified: 2015-08-25 06:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 06:33:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (3.82 KB, text/plain)
2015-08-25 05:45 EDT, Sudhir Menon
no flags Details

  None (edit)
Description Sudhir Menon 2015-08-25 05:45:58 EDT
Created attachment 1066801 [details]
Logs

Description of problem: when "ipa trust-fetch-domains" command is run it runs successfully but displays error message in /var/log/messages 


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-5.el7.x86_64
ipa-server-trust-ad-4.2.0-5.el7.x86_64
ipa-server-dns-4.2.0-5.el7.x86_64


How reproducible:Always reproducible when the command 
"sudo ipa trust-fetch-domains" is fired.


Steps to Reproduce:
1. Establish trust between IPA server domain and Windows AD domain
2. Ensure IPA Server domain is listed under Windows AD Trust and Services  

[smenon@ipaserver ~]$ sudo ipa trust-find
---------------
1 trust matched
---------------
  Realm name: testqa.in
  Domain NetBIOS name: TESTQA
  Domain Security Identifier: S-1-5-21-1521174288-3006602325-1802481311
  Trust type: Active Directory domain
----------------------------
Number of entries returned 1
----------------------------

3.Now run the below command
[smenon@ipaserver ~]$ sudo ipa trust-fetch-domains


Actual results:
The command executes and displays the below output which is correct since there are no subdomains in the test enviornment, but when we check /var/log/messages it displays the below.

Aug 25 14:57:08 ipaserver python2: detected unhandled Python exception in '/usr/libexec/ipa/com.redhat.idm.trust-fetch-domains'
Aug 25 14:57:08 ipaserver abrt-server: Package 'ipa-server-trust-ad' isn't signed with proper key
Aug 25 14:57:08 ipaserver abrt-server: 'post-create' on '/var/spool/abrt/Python-2015-08-25-14:57:08-9372' exited with 1
Aug 25 14:57:08 ipaserver abrt-server: Deleting problem directory '/var/spool/abrt/Python-2015-08-25-14:57:08-9372'


Expected results: exception messages should be fixed.


Additional info: Attachment

Related Bugs.
https://bugzilla.redhat.com/show_bug.cgi?id=1250190
https://bugzilla.redhat.com/show_bug.cgi?id=1250192

Note You need to log in before you can comment on or make changes to this bug.