This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256704 - Feature req: exit with error in case of absence /dev/virtio-ports/com.redhat.spice.0
Feature req: exit with error in case of absence /dev/virtio-ports/com.redhat....
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-vdagent (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: 7.2
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 05:55 EDT by Andrei Stepanov
Modified: 2016-11-03 23:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: spice-vdagent-0.14.0-11.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:42:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Stepanov 2015-08-25 05:55:41 EDT
Suppose host was somehow configured without spicevmc

Spice-vdagent exits silently without any notification 

It is good to have somewhere info why spice-vdagent has failed to start.

strace shows me such info:

3685  stat("/dev/virtio-ports/com.redhat.spice.0", 0x7fff8c3c3e30) = -1 ENOENT (No such file or directory)
3685  exit_group(0)                     = ?
3685  +++ exited with 0 +++

Why retcode is 0? spice-vdagent failed to start.
Comment 2 Christophe Fergeau 2015-09-07 11:12:27 EDT
Sent http://lists.freedesktop.org/archives/spice-devel/2015-September/021856.html upstream
Comment 4 Mike McCune 2016-03-28 19:26:37 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 errata-xmlrpc 2016-11-03 23:42:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2323.html

Note You need to log in before you can comment on or make changes to this bug.