Bug 1256705 - [RFE] User whitelisting for abrt
Summary: [RFE] User whitelisting for abrt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matej Habrnal
QA Contact: Martin Kyral
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1254457 1269889
TreeView+ depends on / blocked
 
Reported: 2015-08-25 09:57 UTC by jigar
Modified: 2019-10-10 10:06 UTC (History)
8 users (show)

Fixed In Version: abrt-2.0.8-38.el6
Doc Type: Enhancement
Doc Text:
User and group whitelisting added to *abrt* Previously, *abrt* allowed all users to generate and collect core dumps, which could potentially enable any user to maliciously generate a large number of core dumps and waste system resources. This update adds a whitelisting functionality to *abrt*, and you can now only allow specific users or groups to generate core dumps. Use the new `AllowedUsers = user1, user2, ...` and `AllowedGroups = group1, group2, ...` options in the `/etc/abrt/plugins/CCpp.conf` configuration file to restrict core dump generation and collection to these users or groups, or leave these options empty to configure *abrt* to process core dumps for all users and groups.
Clone Of:
: 1277849 (view as bug list)
Environment:
Last Closed: 2016-05-11 00:38:24 UTC
mhabrnal: needinfo+


Attachments (Terms of Use)
Patch (4.42 KB, patch)
2016-01-13 09:32 UTC, Matej Habrnal
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0920 normal SHIPPED_LIVE abrt bug fix and enhancement update 2016-05-10 22:53:00 UTC

Description jigar 2015-08-25 09:57:35 UTC
Description of problem: Customer is running ABRT on the OpenShift Online public cloud and they would like to select specifically users they want to collect core dumps from. This is due to fact that non-paid user could DDoS their nodes by generating a large number of dumps and crash abrt itself. Also, it is not sufficient to have this handling in the event hooks, as these are run only after the coredump is generated and saved.

Version-Release number of selected component (if applicable): abrt-2.0.8-30

How reproducible:
Always

Actual results:
ABRT allows all the users to collect coredumps.

Expected results:
ABRT should allow selecting specific users to collect coredumps from.

Comment 2 Matej Habrnal 2015-11-23 08:57:19 UTC
What about implement the user whitelisting by adding a new group? The coredumps will be collected only form the users which are in the group.

The solution offers better manipulation and readability than add a list of users to the CCpp.conf file. Also, in the case there are a lot of whitelisted users, the solution with list in CCpp.conf will be slower.

Conclusion:
Create a new group (something like "abrt_dumpable"). If there are no users in the group, coredumps will be collected from all users. If there are some users in the group, coredumps will be collected only from these users.

Are you ok with this approach?

Comment 3 Jakub Filak 2015-11-23 13:06:11 UTC
Well, such approach would be a little bit confusing and error prone. I would rather switch from user whitelisting to group whitelisting.

Comment 4 Jakub Filak 2015-11-25 09:51:35 UTC
How about to enable both user and group white listing?

AllowedUsers = root
AllowedGroups = wheel

The logic would be the following:
 - if both options are not-defined or empty keep all core dumps
 - else if crashed UID is in the list of users keep the core dump
 - else if crashed UID belongs to a group in the list of groups keep the core dump

Comment 8 Matej Habrnal 2016-01-13 09:32:39 UTC
Created attachment 1114349 [details]
Patch

Comment 10 Matej Habrnal 2016-01-13 11:52:58 UTC
Move back to the POST status, because of the missing dependency to right libreport's version.

Comment 11 jigar 2016-02-22 09:23:23 UTC
Hi,

The customer is ready to accept the proposed workaround. 

Thanks & Regards,
Jigar Raisinghani

Comment 17 errata-xmlrpc 2016-05-11 00:38:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0920.html


Note You need to log in before you can comment on or make changes to this bug.