Bug 1256715 - Executing user-del --preserve twice removes the user pernamently
Executing user-del --preserve twice removes the user pernamently
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 06:21 EDT by Martin Bašti
Modified: 2015-11-19 07:05 EST (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.2.0-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user_del_preserve (950 bytes, text/plain)
2015-09-10 04:50 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Martin Bašti 2015-08-25 06:21:25 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5234

{{{
[root@vm-200 ~]# ipa user-del --preserve jjj
------------------
Deleted user "jjj"
------------------
}}}
User was moved to deleted container
{{{
[root@vm-200 ~]# ipa user-del --preserve jjj
------------------
Deleted user "jjj"
------------------
}}}
User was removed from database at all
{{{
[root@vm-200 ~]# ipa user-del --preserve jjj
ipa: ERROR: no such entry
}}}
Comment 3 Abhijeet Kasurde 2015-09-10 04:50:36 EDT
Created attachment 1072061 [details]
user_del_preserve
Comment 4 Abhijeet Kasurde 2015-09-10 04:51:42 EDT
Verified fix using IPA server : ipa-server-4.2.0-8.el7.x86_64
Marking bug as verified.
Comment 5 errata-xmlrpc 2015-11-19 07:05:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.