Bug 1256731 - /usr/lib64/nagios/plugins/check_mysql looks in the wrong place for .my.cnf
/usr/lib64/nagios/plugins/check_mysql looks in the wrong place for .my.cnf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Scott Wilkerson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 06:54 EDT by Alain D D Williams
Modified: 2015-10-05 07:56 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.0.3-3.fc21 nagios-plugins-2.0.3-3.el6 nagios-plugins-2.0.3-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 19:18:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain D D Williams 2015-08-25 06:54:01 EDT
Description of problem:
A long set up nagios config broke with the recent Redhat 6.7 update.

/usr/lib64/nagios/plugins/check_mysql  --username=nagiostest

This is in fact described in the file /etc/nagios/objects/commands.cfg
       command_line    env HOME=/var/spool/nagios/ $USER1$/check_mysql --username=nagiostest

This has not changed.

Version-Release number of selected component (if applicable):

  
How reproducible:

Every time
  
Steps to Reproduce:
1.
Hack to test: /etc/passwd - set nagios login shell to /bin/bash so that su -c works
2.
Set up a mysql user nagiostest with password SecretWord
3.
Create ~nagios/.my.cnf containing:
[client]
password=SecretWord
4.
Run:
su nagios -c '/usr/lib64/nagios/plugins/check_mysql  --username=nagiostest'
  
Observe that there is output
5.
Do the recent nagios upgrade
6.
Repeat step 4 and watch it fail.
7.
ln ~nagios/.my.cnf /var/spool/nagios/..cnf
8.
Repeat 4. and it will work again.
Comment 1 Pavel Raykov 2015-08-31 07:12:38 EDT
Faced with the same problem. Just to cross-reference: https://bugs.centos.org/view.php?id=9333
Comment 2 Fedora Admin XMLRPC Client 2015-08-31 11:11:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2015-08-31 11:16:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Scott Wilkerson 2015-09-11 12:44:38 EDT
I was able to replicate this issue and am working on a patch to apply and send upstream.
Comment 5 Fedora Update System 2015-09-11 14:25:33 EDT
nagios-plugins-2.0.3-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8046
Comment 6 Fedora Update System 2015-09-11 14:25:38 EDT
nagios-plugins-2.0.3-3.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15637
Comment 7 Fedora Update System 2015-09-11 14:25:42 EDT
nagios-plugins-2.0.3-3.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8047
Comment 8 Fedora Update System 2015-09-11 14:25:48 EDT
nagios-plugins-2.0.3-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15638
Comment 9 Fedora Update System 2015-09-12 17:25:19 EDT
nagios-plugins-2.0.3-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update nagios-plugins'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15636
Comment 10 Fedora Update System 2015-09-12 23:49:11 EDT
nagios-plugins-2.0.3-3.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update nagios-plugins'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15637
Comment 11 Fedora Update System 2015-09-13 00:20:22 EDT
nagios-plugins-2.0.3-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update nagios-plugins'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15638
Comment 12 Fedora Update System 2015-09-13 21:50:34 EDT
nagios-plugins-2.0.3-3.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update nagios-plugins'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8047
Comment 13 Fedora Update System 2015-09-13 22:49:35 EDT
nagios-plugins-2.0.3-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update nagios-plugins'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8046
Comment 14 Fedora Update System 2015-09-14 19:17:59 EDT
nagios-plugins-2.0.3-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-09-18 16:56:23 EDT
nagios-plugins-2.0.3-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15638
Comment 16 Fedora Update System 2015-09-19 14:54:59 EDT
nagios-plugins-2.0.3-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-09-21 12:42:04 EDT
nagios-plugins-2.0.3-3.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-10-01 14:56:12 EDT
nagios-plugins-2.0.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-10-01 20:25:23 EDT
nagios-plugins-2.0.3-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Jan Wagner 2015-10-05 07:56:41 EDT
Just for the records. This issue is fixed by the origin Plugins Maintainer in monitoring-plugins since 3.4.2014 in the VCS and with the release of monitoring-plugins 2.1.1.

Cheers, Jan.

Note You need to log in before you can comment on or make changes to this bug.