Bug 1256742 - Selinux context is changed after rhev-h 6.7 3.5.4 upgrade/reboot on /config/etc/sysconfig/network-scripts/ifcfg-*
Selinux context is changed after rhev-h 6.7 3.5.4 upgrade/reboot on /config/e...
Status: CLOSED DUPLICATE of bug 1252268
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Virtualization Bugs
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 07:21 EDT by Michael Burman
Modified: 2016-02-10 15:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 05:08:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs_rhev-h 6.7 (313.46 KB, application/x-gzip)
2015-08-25 07:21 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2015-08-25 07:21:01 EDT
Created attachment 1066825 [details]
Logs_rhev-h 6.7

Description of problem:
Selinux context is changed after rhev-h 6.7 (3.5.4) upgrade/reboot on /config/etc/sysconfig/network-scripts/ifcfg-*

[root@pink-vds2 ~]# ls -lZ /config/etc/sysconfig/network-scripts/ifcfg-*
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-bond0
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth0
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth1
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth2
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth3
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth3.163
-rw-rw-r--. root root system_u:object_r:file_t:s0      /config/etc/sysconfig/network-scripts/ifcfg-eth3.166
-rw-r--r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-lo
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-net_lb
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-queue
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-rhevm
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-t1

Version-Release number of selected component (if applicable):
ovirt-node-3.2.3-19.el6.noarch
rhevm-3.5.4.2-1.3.el6ev.noarch
20150512.0.el6ev >> rhev-hypervisor6-6.7-20150823.0.el6ev
vdsm-4.16.13.1-1.el6ev.x86_64 >> vdsm-4.16.26-1.el6ev

Steps to Reproduce:
1. upgrade rhev-h 6.6 - 20150512.0.el6ev >> rhev-hypervisor6-6.7-20150823.0.el6ev
vdsm-4.16.13.1-1.el6ev.x86_64 >> vdsm-4.16.26-1.el6ev
2. check for selinux context on ifcfg-* files under /config 

Actual results:
Selinux context is changed for some of the ifcfg-* files ^^

Expected results:
Selinux shouldn't changed after upgrade/reboot
Comment 2 Chaofeng Wu 2015-09-01 07:33:28 EDT
Cat not reproduce this issue on rhev-hypervisor6-6.7-20150828.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.7-20150828
ovirt-node-3.2.3-20.el6.noarch
vdsm-4.16.26-1.el6ev.x86_64

Test steps:
1. PXE install rhev-h 6.6-20150512, configure eth2 and register to RHEV-M3.5.4
2. On RHEV-M web portal, the host status is up, then create eth0 and eth1 as bond0, create Network testnet0 and drag to bond0, create Network testnet1 and drag to eth3, save.
3. All the networks are up, then reboot the system, upgrade to rhev-hypervisor6-6.7-20150828
4. Reboot the system twice.

Test result:
After step4, all the Selinux context seems fine.

[root@localhost ~]# ll -Z /config/etc/sysconfig/network-scripts/ifcfg-*
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-bond0
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-eth0
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-eth1
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-eth2
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-eth3
-rw-r--r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-lo
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-rhevm
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-testnet0
-rw-rw-r--. root root system_u:object_r:net_conf_t:s0  /config/etc/sysconfig/network-scripts/ifcfg-testnet1

[root@localhost ~]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150828.0.el6ev)
Comment 3 Fabian Deutsch 2015-09-01 11:17:30 EDT
To me this looks like a dupe of bug 1252268.

Michael tested rhev-hypervisor6-6.7-20150823.0.el6ev which (AFAIU) still was affected by bug 1252268. The build tested by comment 2 had a fix for that bug.

Douglas, you fixed the bug, what do you say?
Comment 4 Douglas Schilling Landgraf 2015-09-01 21:42:47 EDT
(In reply to Fabian Deutsch from comment #3)
> To me this looks like a dupe of bug 1252268.
> 
> Michael tested rhev-hypervisor6-6.7-20150823.0.el6ev which (AFAIU) still was
> affected by bug 1252268. The build tested by comment 2 had a fix for that
> bug.
> 
> Douglas, you fixed the bug, what do you say?

Correct, the fix introduced in rhev-hypervisor6-6.7-20150828 should cover this scenario. AFAIK, Michael already tested as well and provided the feedback in mailing list. Based on that, moving the bug to ON_QA. Michael, could you please confirm my statement (just for double check)? 

Thanks!
Comment 5 Michael Burman 2015-09-02 04:14:33 EDT
Hi Douglas, Fabian 

Yes Douglas i can confirm your statement, i reported the issue on rhev-hypervisor6-6.7-20150823.0.el6ev like Fabian wrote. 

I tested rhev-h 6.7 20150826.0.el6ev image and i didn't saw this issue no more.
And like you wrote ^^ "the fix introduced in rhev-hypervisor6-6.7-20150828" and this build based on the image i tested. So we are OK and seems like the issue has been fixed. 

Thanks,
Comment 6 Fabian Deutsch 2015-09-02 05:08:00 EDT
Thanks for the feedback, Michael.

*** This bug has been marked as a duplicate of bug 1252268 ***

Note You need to log in before you can comment on or make changes to this bug.