Bug 1256752 - Cannot import nodes from multiple files that share an IPMI IP [NEEDINFO]
Cannot import nodes from multiple files that share an IPMI IP
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 08:03 EDT by Ryan Brown
Modified: 2016-08-22 07:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 07:10:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lmartins: needinfo? (rybrown)


Attachments (Terms of Use)

  None (edit)
Description Ryan Brown 2015-08-25 08:03:31 EDT
Description of problem:
I encountered this problem when trying to import HP Moonshot nodes. Importing a single node [moonshot-solo.json) succeeded, and I attempted to import a second file (moonshot-all.json) but the second import failed.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Make two inventory JSON files, with one IPMI-bridged node in each
2. Import the first JSON file
3. Attempt to import the second

Actual results:
Exception due to the nodes in the second file sharing an IPMI IP address with an existing ironic node. When importing all nodes in a single file, this works fine and they are allowed to share IPs. 

Expected results:
Import all the nodes

Additional info:
It may be valuable to validate that nodes sharing an IPMI address have a MAC address present, or that they have IPMI bridging information (once that's supported in instackenv.json).
Comment 5 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Lucas Alvares Gomes 2016-05-19 06:14:21 EDT
How was the files being imported? 

I'm afraid this bug should be against the tooling that helps with enrolling nodes in Ironic because Ironic does not natively support importing nodes from files.
Comment 8 Dmitry Tantsur 2016-05-19 06:16:51 EDT
There are 2 problems here: with importing and with introspection. I believe both are fixed, could you please check it?
Comment 10 Dmitry Tantsur 2016-08-22 07:10:53 EDT
Closing as fixed, until proved otherwise :)

Note You need to log in before you can comment on or make changes to this bug.