Bug 1256763 - libreswan-3.15 is available
libreswan-3.15 is available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreswan (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 08:23 EDT by Upstream Release Monitoring
Modified: 2016-01-21 11:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 11:30:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2015-08-25 08:23:04 EDT
Latest upstream release: 3.15
Current version/release in rawhide: 3.13-2.fc23
URL: http://download.libreswan.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-08-25 08:23:19 EDT
Failed to kick off scratch build.

list index out of range
Comment 2 Paul Wouters 2015-09-02 09:39:57 EDT
It seems rawhide has a newer kernel/XFRM includes files that are not yet supported by upstream and need work, so this version does not build in rawhide yet.
Comment 3 Johannes Kern 2015-09-15 13:20:04 EDT
I'm currently using libreswan 3.13 in RHEL6 via EPEL. As libreswan versions up until 3.14 are vulnerable to CVE-2015-3240, I wanted to ask whether libreswan 3.15 will be made available in EPEL?
Comment 4 Paul Wouters 2015-09-15 13:28:12 EDT
I'll bring in 3.15-1

rhel6 extras will get 3.15-2 - we have to be careful because the plan is to remove libreswan from EPEL once that happens.
Comment 5 Paul Wouters 2015-09-16 15:36:40 EDT
so actually, libreswan 3.15 needs libevent-2 not yet present in rhel. This is being introduced into rhel6 extras now, so i dont really want to add libevent2 to epel now. So I will skip epel6 for libreswan.
Comment 6 Johannes Kern 2015-10-05 05:06:15 EDT
Is there a bugzilla entry to add libevent-2 to rhel6 extras? I searched the bugzilla database, but didn't find anything. Well, only older entries which won't be fixed in rhel6.
Comment 7 Paul Wouters 2015-10-06 12:12:56 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1242637

Note You need to log in before you can comment on or make changes to this bug.