Bug 1256781 - Quota command enable is unavailable in this version. [NEEDINFO]
Quota command enable is unavailable in this version.
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.3
All Linux
high Severity high
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 08:39 EDT by György Demarcsek
Modified: 2016-05-11 18:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 21:43:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vmallika: needinfo? (dgy.jr92)


Attachments (Terms of Use)

  None (edit)
Description György Demarcsek 2015-08-25 08:39:14 EDT
Description of problem: Trying to enable quota on a GlusterFS volume results in error message that suggests that the option is not available in the given version, however, it used to be available in earlier releases and I couldn't find in any of the release notes that this feature would have become deprecated/unsupported.


Version-Release number of selected component (if applicable):glusterfs 3.7.3 built on Jul 28 2015 14:28:55 (RPM coming from: baseurl=http://download.gluster.org/pub/gluster/glusterfs/3.7/LATEST/EPEL.repo/epel-$releasever/$basearch/)


How reproducible: Should be reproducible with the same RPM. (Tested on CentOS 6.6)


Steps to Reproduce:
1. Create 2-brick replicated volume on 2-node cluster (probably it's irrelevant, maybe it could be a single brick setup as well, but this was my exact scenario)
2. Start the volume with gluster volume start gvol0
3. Enable quota with gluster volume quota gvol0 enable

Actual results:
quota command failed : Volume quota failed. The cluster is operating at version 30603. Quota command enable is unavailable in this version.

Expected results:
Quota is enabled on gvol0

Additional info: It's strange enough that the error message says version "30603". I don't know exactly how to parse this version number, but it looks a bit suspicious given that I was running 3.7.3
Comment 1 György Demarcsek 2015-08-27 04:56:13 EDT
I checked again, on all nodes the glusterd version. It was the same, 3.7.3, so I reopened this issue.

glusterd --version
glusterfs 3.7.3 built on Jul 28 2015 14:28:55
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2013 Red Hat, Inc. <http://www.redhat.com/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.

Additional info:
uname -r: 2.6.32-504.23.4.el6.x86_64
Comment 2 Vijaikumar Mallikarjuna 2015-12-21 04:38:22 EST
Hi György,

You need to pump up the op-version after upgrading and check if quota enable works

# gluster volume set <volname> cluster.op-version <op-version>

op-version for 3.7.3 is '30703'

Thanks,
Vijay
Comment 3 Vijaikumar Mallikarjuna 2016-02-15 01:53:48 EST
Hi György,

Was the issue solved with the command mentioned in comment# 2?

Thanks,
Vijay
Comment 4 Vijaikumar Mallikarjuna 2016-04-06 21:43:11 EDT
As per comment#2, closing as not a bug

Note You need to log in before you can comment on or make changes to this bug.