Bug 1256799 - Updated x2goclient overrides user assigned shell with /bin/bash
Updated x2goclient overrides user assigned shell with /bin/bash
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: x2goclient (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
http://bugs.x2go.org/cgi-bin/bugrepor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 09:14 EDT by Reilly Hall
Modified: 2015-09-18 15:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0.5.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 20:22:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reilly Hall 2015-08-25 09:14:53 EDT
Description of problem:
After upgrading x2goclient my system assigned shell of /bin/zsh is ignored and forcefully set to /bin/bash


Version-Release number of selected component (if applicable):
Affected version:
x2goclient-4.0.5.0-1.fc22.x86_64
Last working version:
x2goclient-4.0.3.2-1.fc22.x86_64


How reproducible:
Very, just upgrade to 4.0.5 and my shell is not set correctly.
Downgrade to 4.0.3 and my shell is set back to zsh.
Forget to use versionlock and yum-cron updates back to 4.0.5 overnight and shell set back to /bin/bash after next morning's login.

Steps to Reproduce:
1. Set your shell to something other than /bin/bash
2. Upgrade x2goclient on the client machine.
3. Login into the machine where you use a shell other than /bin/bash

Actual results:
System shell setting overridden.


Expected results:
My system shell setting to be respected.


Additional info:
Something somewhere is setting my $SHELL environment variable to /bin/bash only when I log into this machine remotely via x2go from a client machine where x2goclient has been upgraded to version 4.0.5, when I downgrade it back to 4.0.3 it works as expected.
Comment 1 Orion Poplawski 2015-08-25 13:30:07 EDT
Looks like I've figured this out and should have a fix shortly.
Comment 2 Fedora Update System 2015-08-25 14:01:37 EDT
x2goclient-4.0.5.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14274
Comment 3 Fedora Update System 2015-08-25 14:01:48 EDT
x2goclient-4.0.5.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14275
Comment 4 Reilly Hall 2015-08-25 15:16:11 EDT
Whoa that was test.  I will test as here shortly.
Comment 5 Reilly Hall 2015-08-25 15:59:05 EDT
Just tried the new version and it works.  My shell is set back to /bin/zsh.  Thank you so very much.  That was fast, I really appreciate it!
Comment 6 Fedora Update System 2015-08-26 00:25:01 EDT
x2goclient-4.0.5.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update x2goclient'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14275
Comment 7 Fedora Update System 2015-08-26 13:27:02 EDT
x2goclient-4.0.5.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update x2goclient'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14274
Comment 8 Reilly Hall 2015-09-08 09:38:21 EDT
I've been using the 4.0.5.0-2.fc22 version for over a week now without any other issues.  Any chance we can have this approved to be released to general updates?  Or is there a minimum amount of time it has to be in testing?
Comment 9 Orion Poplawski 2015-09-08 10:52:38 EDT
Commenting in the update itself is generally the best place to give feedback.  That said looks like the updated updates system is no longer sending me nag mail saying updates can be pushed.
Comment 10 Reilly Hall 2015-09-08 12:29:22 EDT
Ok, excellent.  And thanks again for fixing this.  I know not many people use a shell other than bash, but after I switched to zsh I just couldn't go back, so I really appreciate you fixing this because I use x2go almost daily.
Comment 11 Fedora Update System 2015-09-08 20:22:19 EDT
x2goclient-4.0.5.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-09-18 15:01:25 EDT
x2goclient-4.0.5.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.