Bug 1256800 - [abrt] x2goclient: SessionManageDialog::slot_endisable(): x2goclient killed by SIGSEGV
[abrt] x2goclient: SessionManageDialog::slot_endisable(): x2goclient killed b...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: x2goclient (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a1ef4c39ab3d00fd947993ba905...
:
: 1280157 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 09:18 EDT by Paulo Fidalgo
Modified: 2016-04-05 10:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: x2goclient-4.0.5.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 10:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (117.55 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: core_backtrace (18.13 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: dso_list (11.48 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: environ (2.35 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: maps (60.05 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: mountinfo (3.16 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: open_fds (1.23 KB, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: proc_pid_status (986 bytes, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details
File: var_log_messages (298 bytes, text/plain)
2015-08-25 09:18 EDT, Paulo Fidalgo
no flags Details

  None (edit)
Description Paulo Fidalgo 2015-08-25 09:18:38 EDT
Description of problem:
I was updating the settings of a running connection. Changed the quality settings to default and enabled audio.

Version-Release number of selected component:
x2goclient-4.0.5.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/x2goclient
crash_function: SessionManageDialog::slot_endisable
executable:     /usr/bin/x2goclient
global_pid:     28760
kernel:         4.0.8-300.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 SessionManageDialog::slot_endisable at ../src/sessionmanagedialog.cpp:205
 #1 QMetaObject::activate at kernel/qobject.cpp:3567
 #2 QTreeWidget::currentItemChanged at .moc/release-shared/moc_qtreewidget.cpp:269
 #3 QMetaObject::activate at kernel/qobject.cpp:3567
 #4 QItemSelectionModel::currentChanged at .moc/release-shared/moc_qitemselectionmodel.cpp:172
 #5 QItemSelectionModel::clear at itemviews/qitemselectionmodel.cpp:1123
 #6 QTreeWidget::clear at itemviews/qtreewidget.cpp:3273
 #7 SessionManageDialog::loadSessions at ../src/sessionmanagedialog.cpp:142
 #8 SessionManageDialog::slot_edit at ../src/sessionmanagedialog.cpp:251
 #9 QMetaObject::activate at kernel/qobject.cpp:3567
Comment 1 Paulo Fidalgo 2015-08-25 09:18:42 EDT
Created attachment 1066861 [details]
File: backtrace
Comment 2 Paulo Fidalgo 2015-08-25 09:18:43 EDT
Created attachment 1066862 [details]
File: cgroup
Comment 3 Paulo Fidalgo 2015-08-25 09:18:45 EDT
Created attachment 1066863 [details]
File: core_backtrace
Comment 4 Paulo Fidalgo 2015-08-25 09:18:46 EDT
Created attachment 1066864 [details]
File: dso_list
Comment 5 Paulo Fidalgo 2015-08-25 09:18:47 EDT
Created attachment 1066865 [details]
File: environ
Comment 6 Paulo Fidalgo 2015-08-25 09:18:48 EDT
Created attachment 1066866 [details]
File: limits
Comment 7 Paulo Fidalgo 2015-08-25 09:18:50 EDT
Created attachment 1066867 [details]
File: maps
Comment 8 Paulo Fidalgo 2015-08-25 09:18:51 EDT
Created attachment 1066868 [details]
File: mountinfo
Comment 9 Paulo Fidalgo 2015-08-25 09:18:53 EDT
Created attachment 1066869 [details]
File: namespaces
Comment 10 Paulo Fidalgo 2015-08-25 09:18:54 EDT
Created attachment 1066870 [details]
File: open_fds
Comment 11 Paulo Fidalgo 2015-08-25 09:18:55 EDT
Created attachment 1066871 [details]
File: proc_pid_status
Comment 12 Paulo Fidalgo 2015-08-25 09:18:56 EDT
Created attachment 1066872 [details]
File: var_log_messages
Comment 13 Orion Poplawski 2015-08-25 13:37:47 EDT
Filed upstream: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=929
Comment 14 Orion Poplawski 2015-11-12 13:40:18 EST
*** Bug 1280157 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2016-03-24 18:36:03 EDT
x2goclient-4.0.5.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-06de180216
Comment 16 Fedora Update System 2016-03-25 19:48:13 EDT
x2goclient-4.0.5.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-06de180216
Comment 17 Fedora Update System 2016-04-05 10:17:53 EDT
x2goclient-4.0.5.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.