Bug 1256850 - [RFE] Ceilometer should run API under mod-wsgi
Summary: [RFE] Ceilometer should run API under mod-wsgi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
: 1367477 (view as bug list)
Depends On:
Blocks: 1392307
TreeView+ depends on / blocked
 
Reported: 2015-08-25 15:16 UTC by Chris Dent
Modified: 2016-12-14 15:14 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: Enhancement
Doc Text:
The Telemetry API (ceilometer-api) now uses apache-wsgi instead of eventlet. When upgrading to this release, ceilometer-api will be migrated accordingly. This change provides greater flexibility for per-deployment performance and scaling adjustments, as well as straightforward use of SSL.
Clone Of:
Environment:
Last Closed: 2016-12-14 15:14:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 293642 None None None 2016-08-19 21:12:15 UTC
OpenStack gerrit 352476 None None None 2016-08-19 21:11:25 UTC

Description Chris Dent 2015-08-25 15:16:09 UTC
Following the lead set by Keystone upstream Ceilometer recommends for production, and is now primarily tested with, apache2 + mod_wsgi and not the ceilometer-api standalone web server.

Downstream packaging for the ceilometer API should be updated accordingly, also following the keystone model (e.g. in puppet-keystone), for OSP 8.

Besides being aligned with existing de facto OpenStack standards for web service deployment this will also provide greater flexibility for per-deployment performance and scaling adjustments as well as straightforward use of SSL.

Comment 5 Mike Burns 2016-04-07 20:47:27 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 8 Pradeep Kilambi 2016-08-26 12:58:50 UTC
*** Bug 1367477 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2016-12-14 15:14:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.