Bug 1256850 - [RFE] Ceilometer should run API under mod-wsgi
[RFE] Ceilometer should run API under mod-wsgi
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: FutureFeature, Triaged
: 1367477 (view as bug list)
Depends On:
Blocks: 1392307
  Show dependency treegraph
 
Reported: 2015-08-25 11:16 EDT by Chris Dent
Modified: 2016-12-14 10:14 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.1.el7ost
Doc Type: Enhancement
Doc Text:
The Telemetry API (ceilometer-api) now uses apache-wsgi instead of eventlet. When upgrading to this release, ceilometer-api will be migrated accordingly. This change provides greater flexibility for per-deployment performance and scaling adjustments, as well as straightforward use of SSL.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:14:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 293642 None None None 2016-08-19 17:12 EDT
OpenStack gerrit 352476 None None None 2016-08-19 17:11 EDT

  None (edit)
Description Chris Dent 2015-08-25 11:16:09 EDT
Following the lead set by Keystone upstream Ceilometer recommends for production, and is now primarily tested with, apache2 + mod_wsgi and not the ceilometer-api standalone web server.

Downstream packaging for the ceilometer API should be updated accordingly, also following the keystone model (e.g. in puppet-keystone), for OSP 8.

Besides being aligned with existing de facto OpenStack standards for web service deployment this will also provide greater flexibility for per-deployment performance and scaling adjustments as well as straightforward use of SSL.
Comment 5 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Pradeep Kilambi 2016-08-26 08:58:50 EDT
*** Bug 1367477 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2016-12-14 10:14:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.