Bug 1256852 - [abrt] vim-X11: vim_free(): gvim killed by SIGABRT
[abrt] vim-X11: vim_free(): gvim killed by SIGABRT
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5455773ef0a21a41a07d67c661b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 11:22 EDT by wuchuanren
Modified: 2015-09-22 20:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.4.827-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 20:23:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.46 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: build_ids (3.20 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: core_backtrace (9.16 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: dso_list (6.94 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: environ (4.02 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: maps (33.72 KB, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: open_fds (383 bytes, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: proc_pid_status (955 bytes, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details
File: vimbug.txt (156 bytes, text/plain)
2015-08-25 11:22 EDT, wuchuanren
no flags Details

  None (edit)
Description wuchuanren 2015-08-25 11:22:04 EDT
Description of problem:
with almost default settings, I was writting BNF:

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
cmp_expr		:= cmp_expr_operand + cmp_expr_tail
cmp_expr_tail		:= '==' + 
			 | '!=' + 
			 | '>'  + 
			 | '>=' + 
			 | '<'  + 
			 | '<=' + 
			 | epsilon
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


The  content between <<<< and >>>> are the Fcontent in the buffer, please notice that:
1. the indents are tabs.
2. there is one space after '+' on each lineend

I did the following:
1. select the text "cmp_expr_operand" and copy in the register .
2. block select mode, select all of the spaces after '+' since line 2
3. press p to paste the word in block mode


vim crashes everytime, no matter gvim or in console.


Version-Release number of selected component:
vim-X11-7.4.475-2.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        vi syntax.txt
crash_function: vim_free
executable:     /usr/bin/gvim
kernel:         4.0.8-200.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #36 vim_free at misc2.c:1741
 #37 ml_flush_line at memline.c:3525
 #38 ml_get_buf at memline.c:2499
 #39 ml_get at memline.c:2422
 #40 do_put at ops.c:3809
 #41 nv_put at normal.c:9366
 #42 normal_cmd at normal.c:1160
 #43 main_loop at main.c:1342
Comment 1 wuchuanren 2015-08-25 11:22:07 EDT
Created attachment 1066901 [details]
File: backtrace
Comment 2 wuchuanren 2015-08-25 11:22:09 EDT
Created attachment 1066902 [details]
File: build_ids
Comment 3 wuchuanren 2015-08-25 11:22:10 EDT
Created attachment 1066903 [details]
File: cgroup
Comment 4 wuchuanren 2015-08-25 11:22:11 EDT
Created attachment 1066904 [details]
File: core_backtrace
Comment 5 wuchuanren 2015-08-25 11:22:13 EDT
Created attachment 1066905 [details]
File: dso_list
Comment 6 wuchuanren 2015-08-25 11:22:14 EDT
Created attachment 1066906 [details]
File: environ
Comment 7 wuchuanren 2015-08-25 11:22:15 EDT
Created attachment 1066907 [details]
File: limits
Comment 8 wuchuanren 2015-08-25 11:22:17 EDT
Created attachment 1066908 [details]
File: maps
Comment 9 wuchuanren 2015-08-25 11:22:18 EDT
Created attachment 1066909 [details]
File: open_fds
Comment 10 wuchuanren 2015-08-25 11:22:20 EDT
Created attachment 1066910 [details]
File: proc_pid_status
Comment 11 wuchuanren 2015-08-25 11:22:21 EDT
Created attachment 1066911 [details]
File: vimbug.txt
Comment 12 Fedora Update System 2015-09-02 07:46:49 EDT
vim-7.4.827-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14209
Comment 13 Fedora Update System 2015-09-22 20:22:13 EDT
vim-7.4.827-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.