Bug 1256863 - Two tests not scheduled to run indicate a pass status
Two tests not scheduled to run indicate a pass status
Status: CLOSED DUPLICATE of bug 1254394
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification (Show other bugs)
1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 11:39 EDT by HP Enterprise Cert team
Modified: 2015-09-22 11:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 11:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testresults1.jpg (75.64 KB, image/jpeg)
2015-08-25 11:39 EDT, HP Enterprise Cert team
no flags Details
testresults2.jpg (49.33 KB, image/jpeg)
2015-08-25 11:42 EDT, HP Enterprise Cert team
no flags Details
1GigEthernet.jpg (41.63 KB, image/jpeg)
2015-08-25 11:43 EDT, HP Enterprise Cert team
no flags Details
fv_memory.jpg (37.13 KB, image/jpeg)
2015-08-25 11:43 EDT, HP Enterprise Cert team
no flags Details

  None (edit)
Description HP Enterprise Cert team 2015-08-25 11:39:47 EDT
Created attachment 1066914 [details]
testresults1.jpg

Description of problem:
On a RHEL6.7 SUT selected these tests to run - memory, core, cpuscaling, profiler & video. Once testing complete one of the 1GigEthernet tests and the fv_memory test both report a pass yet the log is empty which indicates the test was not run as expected. Since these two tests were not scheduled to run and did not run they should not report a pass.
See attached testresults1&2.jpg for testing summary.
See attached 1GigEthernet.jpg & fv_memory.jpg for empty test log details.

Version-Release number of selected component (if applicable):
Per Gary Case using a network server with RHEL7.1.
Network Server Cert Kit:
dt-15.14-2.el7.x86_64
lmbench-3.0a7-7b.EL7.x86_64
stress-0.18.8-1.4.el7.x86_64
redhat-certification-1.0-20150723.el7.noarch
redhat-certification-information-1.7.1-20150618.el7.noarch
redhat-certification-hardware-1.7.1-20150618.el7.noarch

RHEL6.7 SUT Cert Kit:
dt-15.14-2.EL6.x86_64
lmbench-3.0a7-6a.EL6.x86_64
stress-0.18.8-1.3.EL6.x86_64
redhat-certification-1.0-20150723.el6.noarch
redhat-certification-hardware-1.6.6-20150818.el6.noarch
redhat-certification-information-1.6.6-20150818.el6.noarch

How reproducible: always

Steps to Reproduce:
1. Register the RHEL6.7 x86_64 SUT
2. Select hardware certification - RHEL6.7
3. Schedule these tests to run - memory, core, cpuscaling, profiler & video

Actual results:
These scheduled tests pass each with the expected log file data - memory, core, cpuscaling, profiler & video. In addition one of the 1GigEthernet tests & fv_memory test report a pass yet the log is empty.

Expected results:
Only the tests actually run, memory, core, cpuscaling, profiler & video should report a pass/fail status.

Additional info: SUT registration using hostnames resolved via the /etc/hosts file.
Comment 1 HP Enterprise Cert team 2015-08-25 11:42:30 EDT
Created attachment 1066916 [details]
testresults2.jpg
Comment 2 HP Enterprise Cert team 2015-08-25 11:43:00 EDT
Created attachment 1066917 [details]
1GigEthernet.jpg
Comment 3 HP Enterprise Cert team 2015-08-25 11:43:28 EDT
Created attachment 1066918 [details]
fv_memory.jpg
Comment 4 Chris Tatman 2015-09-10 08:47:58 EDT
Hi Ben,

Does HP need to supply you with any other details to help with this bug?  Thanks!

--Chris
Comment 5 Greg Nichols 2015-09-10 08:50:12 EDT
The tests that were not run being reported as PASS - is this in the Web UI?
Comment 6 HP Enterprise Cert team 2015-09-21 16:38:45 EDT
Yes, this is seen on the Network Test Server web browser interface where the tests were launched and the test status reported.

Mark C.
Comment 7 Greg Nichols 2015-09-22 11:24:35 EDT

*** This bug has been marked as a duplicate of bug 1254394 ***

Note You need to log in before you can comment on or make changes to this bug.