Bug 1256870 - KDC sends multiple requests to ipa-otpd for the same authentication
KDC sends multiple requests to ipa-otpd for the same authentication
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: krb5 (Show other bugs)
7.1
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Robbie Harwood
Patrik Kis
: ZStream
Depends On: 1251586
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 11:50 EDT by Jaroslav Reznik
Modified: 2015-09-23 13:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: krb5-1.12.2-15.el7_1
Doc Type: Bug Fix
Doc Text:
Previously, the RADIUS support (libkrad) in krb5 was sending krb5 authentication for Transmission Control Protocol (TCP) transports multiple times, accidentally using a code path intended to be used only for unreliable transport types, for example User Datagram Protocol (UDP) transports. A patch that fixes the problem by disabling manual retries for reliable transports, such as TCP, has been applied, and the correct code path is now used in this situation.
Story Points: ---
Clone Of: 1251586
Environment:
Last Closed: 2015-09-15 08:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2015-08-25 11:50:57 EDT
This bug has been copied from bug #1251586 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 4 Roland Mainz 2015-08-26 17:27:58 EDT
Taking (and accepting) bug myself...
Comment 10 errata-xmlrpc 2015-09-15 08:40:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1773.html

Note You need to log in before you can comment on or make changes to this bug.