Bug 1256871 - devmapper.pc: Requires: pkgconfig(....) missing
devmapper.pc: Requires: pkgconfig(....) missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1240061
  Show dependency treegraph
 
Reported: 2015-08-25 11:51 EDT by Ralf Corsepius
Modified: 2015-08-27 04:28 EDT (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.129-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 04:28:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2015-08-25 11:51:10 EDT
Description of problem:

The fc24 device-mapper-devel rpm lacks the "R: pkgconfig()":
# rpm -q --requires -p device-mapper-devel-1.02.105-1.fc24.x86_64.rpm  | grep pkgconfig
..
pkgconfig

For comparison, the same for fc23:
# rpm -q --requires -p device-mapper-devel-1.02.102-2.fc23.x86_64.rpm | grep pkgconfig
...
pkgconfig
pkgconfig(libselinux)
pkgconfig(libudev)


Version-Release number of selected component (if applicable):
device-mapper-devel-1.02.105-1.fc24

Additional info:
- I am not sure who is to blame: the lvm2 packaging or rpm. 
  I would not want to exclude this could be a regression in rpm.
- This bug already is causing FTBFSs in other packages.
Comment 1 Ralf Corsepius 2015-08-25 12:07:07 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1256862
seems to be the cause of this bug.

Proof: When removing librt/@RT_PC@ from libdm/libdevmapper.pc.in by brute force, the device-mapper-devel package receives the missing pkgconfig(...) deps.

diff --git a/lvm2.spec b/lvm2.spec
index 0fe4a89..5a47840 100644
--- a/lvm2.spec
+++ b/lvm2.spec
@@ -103,6 +103,7 @@ or more physical volumes and creating one or more logical volumes
 %setup -q -n LVM2.%{version}
 %patch0 -p1 -b .preferred_names
 %patch1 -p1 -b .udev_no_mpath
+sed -i -e 's, @RT_PC@,,' libdm/libdevmapper.pc.in
 
 %build
 %define _default_pid_dir /run


# rpm -q --requires -p results_lvm2/2.02.128/1.fc24/device-mapper-devel-1.02.105-1.fc24.x86_64.rpm | grep pkgconfig
pkgconfig
pkgconfig(libselinux)
pkgconfig(libudev)
Comment 2 Peter Rajnoha 2015-08-27 04:28:47 EDT
Fixed in lvm2-2.02.129-1.fc24/device-mapper-1.02.106-1.fc24.

Note You need to log in before you can comment on or make changes to this bug.