This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256878 - Novnc should be set up with https
Novnc should be set up with https
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
medium Severity unspecified
: z5
: 5.0 (RHEL 6)
Assigned To: Martin Magr
nlevinki
: Triaged, ZStream
Depends On: 1115896
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 12:02 EDT by Jon Schlueter
Modified: 2015-09-10 07:36 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-packstack-2014.1.1-0.47.dev1288.el6ost
Doc Type: Bug Fix
Doc Text:
Previously novnc consoles were not functional when OpenStack Horizon was configured to run via HTTPS. This release fixes invalid configuration, so consoles are available also via HTTPS.
Story Points: ---
Clone Of: 1115896
Environment:
Last Closed: 2015-09-10 07:36:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 109011 None None None Never
OpenStack gerrit 125055 None None None Never
OpenStack gerrit 210450 None None None Never

  None (edit)
Comment 3 nlevinki 2015-08-31 09:46:26 EDT
I install openstack using packstack with CONFIG_HORIZON_SSL=n.
try to access the horizon using https:// and failed
then I change CONFIG_HORIZON_SSL=y in packstack answer file and reinstall.
then tried to access horizon using https:// and it worked.
Comment 6 errata-xmlrpc 2015-09-10 07:36:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1747.html

Note You need to log in before you can comment on or make changes to this bug.