Bug 125688 - iwconfig hangs when trying to use ndiswrapper 0.7 with WEP
iwconfig hangs when trying to use ndiswrapper 0.7 with WEP
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: modutils (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-09 23:18 EDT by Vadim Gritsenko
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 07:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Gritsenko 2004-06-09 23:18:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Installed ndiswrapper-0.7 and bcmwl5 driver for Dell True Mobile card
built into Dell Inspiron 8600.

Attempt to activate wlan0 with system-config-network fails with
message "Segmentation fault", and dmesg shows:


Unable to handle kernel paging request at virtual address fee6b440
 printing eip:
42bb015e
*pde = 00000000
Oops: 0000 [#1]
CPU:    0
EIP:    0060:[<42bb015e>]    Tainted: P
EFLAGS: 00010206   (2.6.5-1.358)
EIP is at ndis_set_wep+0xa2/0x157 [ndiswrapper]
eax: 0000000d   ebx: 40e86220   ecx: 00000003   edx: 0000000d
esi: fee6b440   edi: 2b18bed0   ebp: 40e86000   esp: 2b18beac
ds: 007b   es: 007b   ss: 0068
Process iwconfig (pid: 3178, threadinfo=2b18b000 task=2908b9b0)
Stack: 29094fec 000009ac 2b122800 034e1e40 02135342 0000000d 0000002c
80000000
       0000000d 0213f1ba 034e1e40 290f2000 00000000 fee6b44d 0000000d
fee6b440
       316129fc 00008b2a 0228b4d8 00000001 2b18bf44 00008b2a 0223db68
316129fc
Call Trace:
 [<02135342>] follow_page+0xda/0xe5
 [<0213f1ba>] rw_vm+0x1ce/0x1ea
 [<0223db68>] wireless_process_ioctl+0x2bf/0x59a
 [<42bb00bc>] ndis_set_wep+0x0/0x157 [ndiswrapper]
 [<0223701b>] dev_ioctl+0x24e/0x283
 [<0222ff8f>] sock_ioctl+0x52/0x280
 [<0213816b>] do_brk+0x1a5/0x1d0
 [<0214ea0e>] sys_ioctl+0x1f2/0x224

Code: f3 a5 a8 02 74 02 66 a5 a8 01 74 01 a4 8d 44 24 04 ba 13 01


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get Dell Inspiron 8600 with 802.11g card, ndiswrapper-0.7, and
bcmwl5.dll
2. Follow http://www.linuxelectrons.com/article.php/20040507104718960
(or similar from fedoranews.org)
3. Put WEP key in hexadecimal format

Actual Results:  Segmentation fault, system-config-network hangs.
Subsequent execution of iwconfig hangs.

Expected Results:  Working wireless connection.

Additional info:
Comment 1 Vadim Gritsenko 2004-06-10 08:05:58 EDT
Turns out segmentation fault was caused by WEP; once WEP key is
removed everything is working fine. This [1] also indicates that later
than 0.7 ndiswrapper should have WEP working.

[1] http://article.gmane.org/gmane.linux.drivers.ndiswrapper.general/2116
Comment 2 Vadim Gritsenko 2004-06-10 08:06:46 EDT
(updated summary)
Comment 3 Alan Cox 2004-06-19 07:35:23 EDT
This problem isn't in an Fedora shipped components so should be
reported upstream (if indeed its not fixed in 0.7)

Note You need to log in before you can comment on or make changes to this bug.