Bug 1256900 - [Docs] [Director] Updated image_path documentation
[Docs] [Director] Updated image_path documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: y1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks: 1269041
  Show dependency treegraph
 
Reported: 2015-08-25 13:06 EDT by Keith Schincke
Modified: 2015-12-15 23:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-15 23:56:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Schincke 2015-08-25 13:06:55 EDT
Description of problem:
Section 3.7. Configuring the Director of the installation documentation states the image_path parameter of overcloud.conf should point to the path of the images used for deployment. An emamil from the openstack-management list states this configuration option is unused. This has been replaced with the "--image-path" option to the "openstack overcloud image upload" command. 

The documentation should be updated to remove the mentioning of this option. 
A suggested addition would be mentioning "openstack help overcloud image upload" will display available command options. 

Version-Release number of selected component (if applicable):
http://file.bne.redhat.com/~dmacpher/OpenStack/7.0/Director/#sect-Configuring_the_Director

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Andrew Dahms 2015-08-25 23:36:45 EDT
Assigning to Dan for review.
Comment 5 Dan Macpherson 2015-09-24 22:48:01 EDT
Hi Keith,

I've removed the parameter in the config file:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Configuring_the_Director.html

And replaced it with a CLI option for the image upload command:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Obtaining_Images_for_Overcloud_Nodes.html

Does these changes reflect the requirements needed for this bug? Are there any further changes required?
Comment 6 Dan Macpherson 2015-12-15 23:56:49 EST
No response since September. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.