Bug 1256912 - rhel-osp-director: Remove unused '#image_path =' from undercloud.conf
rhel-osp-director: Remove unused '#image_path =' from undercloud.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
x86_64 Linux
low Severity low
: Upstream M3
: 11.0 (Ocata)
Assigned To: Alex Schultz
Gurenko Alex
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 13:39 EDT by Omri Hochman
Modified: 2017-05-17 15:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: instack-undercloud-6.0.0-2.el7ost
Doc Type: Deprecated Functionality
Doc Text:
The image_path parameter is no longer used. This update removes it from the undercloud configuration file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:23:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1662981 None None None 2017-02-08 13:08 EST
OpenStack gerrit 431094 None None None 2017-02-08 13:09 EST
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 19:01:50 EDT

  None (edit)
Description Omri Hochman 2015-08-25 13:39:27 EDT
rhel-osp-director: Remove unused '#image_path =' from undercloud.conf  


Environment: 
-------------
instack-undercloud-2.1.2-23.el7ost.noarch
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch
instack-0.0.7-1.el7ost.noarch
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-4.el7ost.noarch
openstack-puppet-modules-2015.1.8-9.el7ost.noarch
puppet-3.6.2-2.el7.noarch


Description: 
------------
This configuration option is actually not used at all. It's just something we
forgot to remove from undercloud.conf when we switched to using the unified cli
(python-rdomanager-oscplugin).

If you had the images downloaded to a different directory other than the cwd,
you would specify that path when you run openstack overcloud image upload via
the --image-path cli arg.

This part should be removed from  --> undercloud.conf   :
---------------------------------------------------------
# Local file path to the necessary images. The path should be a
# directory readable by the current user that contains the full set of
# images. (string value)
#image_path = .
Comment 4 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Dmitry Tantsur 2016-10-17 05:16:38 EDT
I can confirm the option is still there, and is still unused (superseded by options of "image upload").
Comment 8 Red Hat Bugzilla Rules Engine 2017-02-08 13:08:23 EST
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 11 Gurenko Alex 2017-04-24 06:39:59 EDT
Verified on build 2017-04-20.2

[stack@undercloud-0 ~]$ rpm -q instack-undercloud
instack-undercloud-6.0.0-6.el7ost.noarch

[stack@undercloud-0 ~]$ grep -i "#image_path" /usr/share/instack-undercloud/undercloud.conf.sample
[stack@undercloud-0 ~]$
Comment 13 errata-xmlrpc 2017-05-17 15:23:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.