Bug 1256963 - [DOCS] Info on how to make applications available via F5 loadbalancer when using edge lbs
[DOCS] Info on how to make applications available via F5 loadbalancer when us...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ashley Hardin
zhaozhanqi
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 17:48 EDT by Ryan Howe
Modified: 2016-08-02 09:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-02 09:20:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-08-25 17:48:50 EDT
Document URL: https://docs.openshift.com/enterprise/3.0/admin_guide/routing_from_edge_lb.html

Section Number and Name:  n/a

Describe the issue: Missing documentation on how to configure Openshift router to talk to the F5 appliance so applications are available via F5 loadbalancer

Suggestions for improvement: Add information on what is needed to be configured for the router when routing from edge LB. 


Additional information:
Comment 1 Ryan Howe 2015-08-25 18:00:36 EDT
Correction from above, documentation needed on how to configure application to be available via the edge LBs
Comment 7 Alex Dellapenta 2015-09-25 17:29:26 EDT
The F5 router was released with OSE 3.0.2. Bulk of the docs updates happened in:

https://github.com/openshift/openshift-docs/pull/980

Affected published docs (the Customer Portal docs are held up due to an unrelated issue, but should be updated in the next few days):

https://docs.openshift.com/enterprise/3.0/architecture/core_concepts/routes.html#f5-router

https://docs.openshift.com/enterprise/3.0/install_config/install/deploy_router.html

There were fixes to the "Routing from Edge LB" topic too:

https://docs.openshift.com/enterprise/3.0/admin_guide/routing_from_edge_lb.html

In hindsight, I realize now I left out linking from the end of the ramp node steps back to the F5 router... I was going to move this to REL_PENDING, but I should probably leave it MODIFIED until that link is in.
Comment 9 Ashley Hardin 2016-07-22 16:32:35 EDT
As Alex notes above, most of this work was previously done:
https://docs.openshift.com/enterprise/3.2/architecture/core_concepts/routes.html#f5-router

https://docs.openshift.com/enterprise/3.2/install_config/install/deploy_router.html

https://docs.openshift.com/enterprise/3.2/install_config/routing_from_edge_lb.html

However, Alex intended to add a link to the F5 content from the Routing from Edge Load Balancers topic. This PR accomplishes that:
https://github.com/openshift/openshift-docs/pull/2543

Once that work is merged, I believe we can close this.
Comment 10 openshift-github-bot 2016-07-29 11:41:59 EDT
Commits pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/92d614ace71cc5702b0199b3bb814d29e21b13fe
Bug 1256963, added link connecting F5 router and Routing from Edge Load Balancers topics

https://github.com/openshift/openshift-docs/commit/9861e649fce9afa7b4142ea0c8a16aa515cf4463
Merge pull request #2543 from ahardin-rh/f5router-links

Bug 1256963, added link connecting F5 router and Routing from Edge LB topics

Note You need to log in before you can comment on or make changes to this bug.