Bug 1256966 - Document the need to regenerate initrd in order to mask files under /usr
Document the need to regenerate initrd in order to mask files under /usr
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 18:20 EDT by Sergio Durigan Junior
Modified: 2015-09-11 02:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 02:43:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Durigan Junior 2015-08-25 18:20:05 EDT
[ I am filing this bug here because I do not use github's proprietary javascript/backend, so I cannot file bugs against upstream systemd anymore. ]

I have been trying to disable/mask the file /usr/lib/sysctl.d/50-coredump.conf , shipped by systemd.  To do that, I have created a file with the same name under /etc/sysctl.d, and symlinked it to /dev/null (as instructed on sysctl.d(5)).  However, I see that /proc/sys/kernel/core_pattern still has the same value (even after a reboot).

I am not sure if this fails every file that you try to mask using this scheme, or if it's just for this coredump thing.  Apparently this worked before.

I am running Fedora 22, x86_64

kernel-3.19.8-100.fc20.x86_64
systemd-219-18.fc22.x86_64
Comment 1 Jan Synacek 2015-08-31 07:27:16 EDT
After you create the masked file, you also have to regenerate the initrd, otherwise only the default configuration (from /usr) stays there and the setting gets propagated to the root filesystem.
Comment 2 Sergio Durigan Junior 2015-08-31 13:08:28 EDT
Thanks for the reply, Jan.  However, I still consider there is room for improvement.  I could not find this information anywhere (is it described on any manual/manpage?), and I do think it is necessary to explicitly mention this nontrivial step of having to regenerate initrd.

I am reopening this bug because of that; I am also changing the title to reflect the new task.
Comment 3 Jan Synacek 2015-09-02 05:42:13 EDT
Merged upstream in https://github.com/systemd/systemd/pull/1118.
Comment 5 Jan Synacek 2015-09-11 02:43:27 EDT
Fixed by https://bodhi.fedoraproject.org/updates/systemd-219-23.fc22

Note You need to log in before you can comment on or make changes to this bug.