Bug 125697 - errors installing essential packages are ignored
errors installing essential packages are ignored
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 05:49 EDT by Fergal Daly
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install log with lots of failures (115.32 KB, text/plain)
2004-06-14 11:36 EDT, Fergal Daly
no flags Details

  None (edit)
Description Fergal Daly 2004-06-10 05:49:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
For some reason (possibly LVM related) my install failed. The first
package that didn't install correctly was glibc-2.3.2-101.i686. This
is clearly an essential package but anaconda continued installing and
didn't mention anything at all.

In the end I got a system with no glibc, no kernel and no bootloader.
No glibc means that I can't even chroot /mnt/sysimage from the rescue
disk.

My suggestion is that there should be some packages who's failure
halts the entire install.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This seems to be reproducible on my system, it happened to me twice
and then I stopped trying to install with LVM and it went away.



Actual Results:  a completely broken system

Expected Results:  a completely broken system but the installer should
have stopped at a much earlier stage and told me about the problem

Additional info:
Comment 1 Jeremy Katz 2004-06-14 11:24:24 EDT
Can you attach the install.log?  We catch pretty much everything that
gets passed back up by rpm.
Comment 2 Fergal Daly 2004-06-14 11:36:43 EDT
Created attachment 101115 [details]
install log with lots of failures
Comment 3 Jeremy Katz 2004-06-14 11:41:21 EDT
scriptlet failures are non-fatal in 99% of cases, and thus ignored. 
If we errored out on every scriptlet failure, then upgrades especially
would never work and installs would be non-functional large chunks of
the time.  The root cause is the glibc %post failure and then that
cascades through.

*** This bug has been marked as a duplicate of 125700 ***
Comment 4 Fergal Daly 2004-06-14 12:08:44 EDT
This is not a duplicate of 125700. I filed both of them as a result of
the same problem but they are about 2 totally different things. 125700
is about error capture and this is about bailing if essential packages
fail to install.

Have a look further down the install.log, you will see

Installing initscripts-7.42-1.i386.
error: %pre(initscripts-7.42-1) scriptlet failed, exit status 0
error:   install: %pre scriptlet failed (2), skipping initscripts-7.42-1

and

Installing kernel-2.4.22-1.2115.nptl.i686.
error: %pre(kernel-2.4.22-1.2115.nptl) scriptlet failed, exit status 0
error:   install: %pre scriptlet failed (2), skipping
kernel-2.4.22-1.2115.nptl

this is not just a scriptlet failure, this is the entire package
failing. What is the point of continuing the install after these failures?

Perhaps there is a point if it's an upgrade (although I think the user
is in for a bit of a surprise) but a clean install should stop when it
hits these errors.

Note You need to log in before you can comment on or make changes to this bug.