Bug 1256989 - capsule removal fails
capsule removal fails
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 22:15 EDT by Pradeep Kumar Surisetty
Modified: 2016-12-13 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-13 09:31:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kumar Surisetty 2015-08-25 22:15:14 EDT
Description of problem:
As part of multi capsule creation, created around 400 capsules on virtual machines. After creating capsules on,  Some of the VM''s had to be removed due to some storage issues.  Once VM image is undefine/deleted, tried to remove capsule from GUI. 

Fails to remove capsules with below error:

vmcapsule319.perf.lab.eng.rdu.redhat.com is used by vmcapsule319.perf.lab.eng.rdu.redhat.com



Version-Release number of selected component (if applicable):

6.1 GA
RHEL 7.1 Satelitte/Capsule

How reproducible:


Steps to Reproduce:
1. create multi capsules on virtual machines and register with satelitte server
2. delete/destroy some VM's. try to remove capsule from GUI. 
3.

Actual results:

Capsule is not getting removed
Expected results:
Capsule should be removed

Additional info:
Comment 1 Brad Buckingham 2015-10-16 07:24:11 EDT
Note: I have observed that in order to delete the capsule, the user must first delete the host associated with it.
Comment 3 Bryan Kearney 2016-07-08 16:47:40 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Chris Roberts 2016-12-13 09:31:40 EST
Based on comment #1 from Brad that is the correct method. This is a sanity check to not cause FK in the postgres table. Once you delete the hosts then you can delete the capsule.

Closing this out

- Chris

Note You need to log in before you can comment on or make changes to this bug.