Bug 125699 - added Apple Bootstrap partition doesn't show up in Disk Druid
added Apple Bootstrap partition doesn't show up in Disk Druid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-06-10 05:57 EDT by Bastien Nocera
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 13:23:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-06-10 05:57:07 EDT
Description of problem:
added Apple Bootstrap partition doesn't show up in Disk Druid

Version-Release number of selected component (if applicable):
10.0-5

How reproducible:
Everytime

Steps to Reproduce:
1. Start the installation, and choose Disk Druid as the way to partition
2. Delete all the partitions, and then create a partition of type
"Apple Bootstrap"
3. the partition doesn't show up in the list, but will be created
*after* all the other partitions

Actual results:
Partition isn't shown and created as /dev/hda4 (partition table is
hda1, then root partition, swap, and finally the bootstrap)

Expected results:
Partition shows up, and is created before the other ones (/dev/hda2)

Additional info:
Entering the Open Firmware (Alt+Option+O+F at boot), and entering
"boot hd:4,\\yaboot" manages to boot the system.
"setenv boot-device hd:4,\\yaboot" to set it as the default.
Comment 1 Paul Nasrat 2004-07-05 10:19:18 EDT
The visibility issue is due to the fix for #119479, I've just commited
a fix to HEAD.
Comment 2 Colin Charles 2004-08-30 12:40:31 EDT
This is fixed, I can verify it. I've seen my Apple Bootstrap partition
with the anaconda from August 30th 2004
(anaconda-10.0.2-0.20040826115153.ppc.rpm)

Note You need to log in before you can comment on or make changes to this bug.