Bug 1257001 - overcloud deployments have no swap configured
overcloud deployments have no swap configured
Status: CLOSED DUPLICATE of bug 1245714
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Jay Dobies
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 23:55 EDT by Fabio Massimo Di Nitto
Modified: 2016-04-18 02:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 01:38:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2015-08-25 23:55:18 EDT
Description of problem:

the machines deployed have no swap partitions configured

Version-Release number of selected component (if applicable):

[stack@instack ~]$ rpm -q -a |grep triple
openstack-tripleo-heat-templates-0.8.6-46.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-4.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-1.git49b57eb.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-6.el7ost.noarch

How reproducible:

always

Steps to Reproduce:
1. deploy overcloud
2.
3.

Actual results:

no swap partitions

Expected results:

swap partitions are created

Additional info:

the most immediate problem is that as soon memory is filling up, kernel will start OOM and killing processes around, without being given a chance to swap less important chunks of RAM into swap.. things go kaboom.
Comment 3 Mike Burns 2015-08-26 01:38:08 EDT

*** This bug has been marked as a duplicate of bug 1245714 ***

Note You need to log in before you can comment on or make changes to this bug.