Bug 1257012 - Fix the tests infra
Fix the tests infra
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
: Triaged
Depends On: 1251592
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 01:08 EDT by Raghavendra Talur
Modified: 2016-04-19 03:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251592
Environment:
Last Closed: 2016-03-10 04:15:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2015-08-26 01:08:06 EDT
+++ This bug was initially created as a clone of Bug #1251592 +++

Description of problem:
Enable easier debugging of tests when they fail in jenkins.

--- Additional comment from Anand Avati on 2015-08-08 18:11:19 IST ---

REVIEW: http://review.gluster.org/11865 (tests: Disable trace mode in G_LOG) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-11 19:43:00 IST ---

REVIEW: http://review.gluster.org/11865 (tests: Disable trace mode in G_LOG) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-13 00:27:53 IST ---

COMMIT: http://review.gluster.org/11865 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit f7e14df044ee5091bc89ad7ad2a7d22092b50be8
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Sat Aug 8 01:53:52 2015 +0530

    tests: Disable trace mode in G_LOG
    
    We run tests in trace mode(set -x) when
    re-running failed tests. G_LOG is a util
    function and it need not be executed in
    trace mode.
    
    Change-Id: I5490bdcacef6856c5501272c8173828c30aaf373
    BUG: 1251592
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11865
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>

--- Additional comment from Anand Avati on 2015-08-17 12:31:57 IST ---

REVIEW: http://review.gluster.org/11933 (tests: Move mount-nfs-auth.t to bad tests) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 12:11:25 IST ---

REVIEW: http://review.gluster.org/11993 (tests: Have unique names for local variables) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 12:59:16 IST ---

REVIEW: http://review.gluster.org/11993 (tests: Fix corruption of files on NetBSD) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 13:15:48 IST ---

REVIEW: http://review.gluster.org/11993 (tests: Fix corruption of files on NetBSD) posted (#4) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-25 12:03:59 IST ---

REVIEW: http://review.gluster.org/11993 (tests: Fix corruption of files on NetBSD) posted (#6) for review on master by Raghavendra Talur (rtalur@redhat.com)

--- Additional comment from Anand Avati on 2015-08-26 09:50:09 IST ---

COMMIT: http://review.gluster.org/11993 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 734e9ed2827c39336e1fab26e2db3ea987976ce1
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Aug 24 12:04:54 2015 +0530

    tests: Fix corruption of files on NetBSD
    
    This is one more attempt to eliminate corruption
    of files by our tests scripts on NetBSD.
    
    Changes done:
    1. Have every local variable with a unique name.
    2. Change date format to match with gluster's.
    3. Pass the parameters to G_LOG without interpretation,
       hence the change from $* to $@.
    
    Change-Id: I833a93555da93179a1b39a9e4e7086216c335c3d
    BUG: 1251592
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/11993
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
Comment 1 Vijay Bellur 2016-02-01 04:12:00 EST
REVIEW: http://review.gluster.org/13328 (tests: refactor option parsing into a function) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Vijay Bellur 2016-02-01 04:12:30 EST
REVIEW: http://review.gluster.org/13328 (tests: refactor option parsing into a function) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Vijay Bellur 2016-02-01 07:57:18 EST
REVIEW: http://review.gluster.org/13328 (tests: refactor option parsing into a function) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 4 Vijay Bellur 2016-02-19 06:23:33 EST
REVIEW: http://review.gluster.org/13475 (tests: include unistd.h for fdatasync) posted (#1) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)
Comment 5 Vijay Bellur 2016-02-19 06:23:58 EST
REVIEW: http://review.gluster.org/13475 (tests: include unistd.h for fdatasync) posted (#2) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)
Comment 6 Vijay Bellur 2016-02-19 06:25:16 EST
REVIEW: http://review.gluster.org/13476 (tests: refactor option parsing into a function) posted (#1) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)
Comment 7 Vijay Bellur 2016-02-23 00:24:23 EST
COMMIT: http://review.gluster.org/13475 committed in release-3.7 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 3f1fba83ad6b077318f85888fafdfb483a62b98e
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Dec 31 16:39:21 2015 +0530

    tests: include unistd.h for fdatasync
    
            Backport of http://review.gluster.org/13128
    
    gcc throws a warning if unistd.h is not included.
    
    Change-Id: Ib08f15117a5e003b204828dbc3954442d80a1964
    BUG: 1257012
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13475
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 8 Vijay Bellur 2016-03-07 01:10:13 EST
REVIEW: http://review.gluster.org/13620 (tests: backport all changes in run-tests.sh) posted (#1) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)
Comment 9 Vijay Bellur 2016-03-07 15:30:18 EST
COMMIT: http://review.gluster.org/13620 committed in release-3.7 by Raghavendra Talur (rtalur@redhat.com) 
------
commit 7681e629ae71fab7f6a04706d2e5ad33a2251737
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Mar 7 11:37:13 2016 +0530

    tests: backport all changes in run-tests.sh
    
    I thought of back porting each patch one after another but it does not
    make sense to put that load on jenkins. I have copied the run-tests.sh
    from master branch to release-3.7.
    
    As discussed on irc in gluster-meeting, it makes sense to have the
    infra code same in all the branches.
    
    Change-Id: I1b111d0f65fbc388f1ee25ea9f50e82205604ad2
    BUG: 1257012
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13620
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 10 Kaushal 2016-04-19 03:21:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 11 Kaushal 2016-04-19 03:23:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.