Bug 1257028 - Can't print an envelope (Oki B4350)
Can't print an envelope (Oki B4350)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: foomatic-db (Show other bugs)
7.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Zdenek Dohnal
Petr Sklenar
: FastFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 02:30 EDT by Todd
Modified: 2017-08-05 02:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: foomatic-db-4.0-41.20130911.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:17:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (70.41 KB, patch)
2017-01-19 16:57 EST, Zdenek Dohnal
no flags Details | Diff
ppd file for Okidata B4350 (12.48 KB, text/plain)
2017-02-06 18:03 EST, Todd
no flags Details

  None (edit)
Description Todd 2015-08-26 02:30:21 EDT
Dear Red Hat,

I am coming from the community: Scientific Linux 7.1.

$ rpm -qa cups
cups-1.6.3-17.el7_1.1.x86_64

$ uname -r
3.10.0-229.11.1.el7.x86_64

Printer: Okidata B4350

I just upgraded to Scientific Linux 7.1 from SL 6.7 (total wipe and fresh install).

Now I can't print an envelope to my Oki B4350.  Paper size mismatch.  CUPS tells my printer that a #10 envelope (Monarch Envelope) is a B5 piece of paper.  overriding the prompt from my printer results in a ruined envelope.

This reproduces from Libre Office and Lotus Approach and Word Pro running under Wine Staging.

Many thanks,
-T
Comment 3 Todd 2015-08-26 18:16:09 EDT
Figured it out.  The ppd you include with CUPS for the Oki B4350 is a NIGHTMARE!

The current ppd for the Oki B4350 fixes the issue:
http://openprinting.org/ppd-o-matic.php?driver=ljet4&printer=Oki-B4350&show=1

Please correct your CUPS rpm to include the proper PPD.

Many thanks,
-T
Comment 4 Todd 2015-08-26 18:19:38 EDT
Here is the link to the Oki B4350 page:

http://openprinting.org/printer/Oki/Oki-B4350
Comment 7 Zdenek Dohnal 2016-10-21 08:07:08 EDT
Hi Todd,

if I fix this bug, would you mind testing it, if it works, please?
Comment 8 Todd 2016-10-21 14:53:10 EDT
Sure.  But there is really nothing to fix.  You just use the ppd from

http://openprinting.org/printer/Oki/Oki-B4350

and ditch the old, bad one
Comment 9 Zdenek Dohnal 2017-01-19 16:56:48 EST
Todd, would you mind trying these rpms https://zdohnal.fedorapeople.org/.foomatic-db/ ?
Comment 10 Zdenek Dohnal 2017-01-19 16:57 EST
Created attachment 1242617 [details]
Proposed patch
Comment 11 Todd 2017-01-20 14:20:32 EST
Hi Zdenek,

"Foomatic" had nothing to do with problem.  It was the ppm that was seriously out-of-date.  After installing the current ppm and only the current ppm (nothing else), the problem was solved.  Foomatic never changed.

The problem is that your ppm's are way, way, seriously out-of-date.\

-T
Comment 12 Zdenek Dohnal 2017-01-23 04:01:32 EST
Todd,

PPD for your printer is supposed to be shipped by foomatic-db package, so IMHO it is foomatic-db problem. Your "installing the current PPD" probably only overwrote ancient PPD shipped by foomatic-db - so my fix is that foomatic-db package will ship current PPD, which should work for you (that's why I asked you to test the package - better to be sure it is working), so you do not have to manually install current PPD.
So would you mind testing these rpms?
Comment 13 Todd 2017-01-23 04:03:22 EST
Hi Zdenek,

No problem, but it may be a week or so till I get enough office time

-T
Comment 14 Todd 2017-02-06 18:03 EST
Created attachment 1248224 [details]
ppd file for Okidata B4350

Hi Zdenek,

I downloaded "foomatic-db-4.0-40.20130911.el7.noarch.rpm" from pbone.net and took a look inside.  There is not a single ppd file included in the package.

I have attached my ppd for you to compare with yours.

-T
Comment 15 Zdenek Dohnal 2017-02-07 04:48:01 EST
Todd,

would you mind downloading and testing rpms from this link https://zdohnal.fedorapeople.org/.foomatic-db/ ? Because rpms from different sources is meaningless for finding out if our rpms are working fine. And ppds are in foomatic-db-ppds subpackage, which should be installed with base foomatic-db package.
Comment 16 Todd 2017-02-23 18:12:40 EST
Hi Zdenek,

The ppd inside:

foomatic-db-ppds-4.0-41.20130911.el7.noarch.rpm/usr/share/foomatic/db/source/PPD/Oki/ok4350u1.ppd.gz

Is identical to the one I downloaded from Open Printing:

http://openprinting.org/ppd-o-matic.php?driver=ljet4&printer=Oki-B4350&show=1


Thank you!

-T
Comment 21 errata-xmlrpc 2017-08-01 18:17:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2028
Comment 22 Todd 2017-08-05 02:03:26 EDT
Thank you!

Note You need to log in before you can comment on or make changes to this bug.