Bug 1257061 - [GSS](6.4.z) access-log relative-to attribute is not physically written to the configuration it the value is the default one
[GSS](6.4.z) access-log relative-to attribute is not physically written to th...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web (Show other bugs)
6.4.2
Unspecified Unspecified
low Severity low
: CR1
: EAP 6.4.16
Assigned To: Dominik Pospisil
Radim Hatlapatka
:
Depends On:
Blocks: eap6416-payload
  Show dependency treegraph
 
Reported: 2015-08-26 04:07 EDT by Tom Fonteyne
Modified: 2017-06-22 05:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-22 05:19:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Fonteyne 2015-08-26 04:07:03 EDT
if relative-to="jboss.server.log.dir" then it it not pohysically written to the configuration. The setup still works as expected, because the server uses the default value anyhow.

reproduce:

# add the access-log entry
/subsystem=web/virtual-server=default-host/configuration=access-log:add

# set both path and relative-to
/subsystem=web/virtual-server=default-host/configuration=access-log/setting=directory:add(path=".",relative-to="jboss.server.log.dir")

# use the CLI to read the actual config:

/subsystem=web/virtual-server=default-host/configuration=access-log/setting=directory:read-resource
{
    "outcome" => "success",
    "result" => {
        "path" => ".",
        "relative-to" => "jboss.server.log.dir"
    },

in xml:

            <virtual-server name="default-host" enable-welcome-root="true">
                <alias name="localhost"/>
                <alias name="example.com"/>
                <access-log>
                    <directory path="."/>
                </access-log>
            </virtual-server>

Note that "relative-to" is not present in xml.

Expectation: that the value is written to xml regardless

Note that using for example a named path, and setting relative-to to that named path, the relative-to is correctly written.

Either way, the server works as expected as the default value is used when not present
Comment 6 Mike McCune 2016-03-28 18:30:10 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Michael Cada 2017-06-06 04:08:03 EDT
Verified with EAP 6.4.16.CP.CR1
Comment 8 Petr Penicka 2017-06-22 05:19:39 EDT
Released on June 20 2017 as part of the EAP 6.4.16 maintenance release.

Note You need to log in before you can comment on or make changes to this bug.