Bug 1257073 - Sending domain info missed when running virt-who -o -d
Sending domain info missed when running virt-who -o -d
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
xingge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 04:42 EDT by gaoshang
Modified: 2016-11-30 19:33 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.14-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:57:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gaoshang 2015-08-26 04:42:24 EDT
Description of problem:
"Sending domain info" section missed when running virt-who -o -d command

Version-Release number of selected component (if applicable):
virt-who-0.14-5.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. run # virt-who -o -d
2. check log in /var/log/rhsm/rhsm.log

Actual results:
"Sending domain info" section missed:
2015-08-26 00:55:58,704 INFO: No configurations found, using libvirt as backend
2015-08-26 00:55:58,704 INFO: Using configuration "env/cmdline" ("libvirt" mode)
2015-08-26 00:55:58,796 INFO: Using libvirt url: ""
2015-08-26 00:55:58,806 DEBUG: Virtual machine found: 7.1_Server_x86_64: 45094b33-56d5-44aa-ba20-e2f8905f120b
2015-08-26 00:55:58,807 DEBUG: Virtual machine found: 6.5_Server_x86_64: ca5dd9fb-07cf-4113-8f56-8eebc5cb9adc
2015-08-26 00:55:58,808 DEBUG: Virtual machine found: 6.7_Server_x86_64: b38cb38a-6d89-41e5-9201-ff56890c7d5a
2015-08-26 00:55:58,808 DEBUG: Libvirt domains found: ['45094b33-56d5-44aa-ba20-e2f8905f120b', 'ca5dd9fb-07cf-4113-8f56-8eebc5cb9adc', 'b38cb38a-6d89-41e5-9201-ff56890c7d5a']
2015-08-26 00:55:59,812 DEBUG: virt-who shut down started

Expected results:
log info should be like:
2015-08-26 00:54:44,403 INFO: No configurations found, using libvirt as backend
2015-08-26 00:54:44,403 INFO: Using configuration "env/cmdline" ("libvirt" mode)
2015-08-26 00:54:44,437 INFO: Using libvirt url: ""
2015-08-26 00:54:44,442 DEBUG: Virtual machine found: 6.7_Server_x86_64: 5ccf097b-c9f9-40af-8a1b-f38811ee4d0c
2015-08-26 00:54:44,443 DEBUG: Virtual machine found: 7.1_Server_x86_64: 255d3011-0665-4b9c-9c9b-dcc12faa00ea
2015-08-26 00:54:44,443 DEBUG: Virtual machine found: 6.5_Server_x86_64: e782d10f-00d7-4989-a54f-3d0292f06f63
2015-08-26 00:54:44,443 DEBUG: Libvirt domains found: ['5ccf097b-c9f9-40af-8a1b-f38811ee4d0c', '255d3011-0665-4b9c-9c9b-dcc12faa00ea', 'e782d10f-00d7-4989-a54f-3d0292f06f63']
2015-08-26 00:54:44,446 DEBUG: Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-08-26 00:54:44,855 INFO: Sending domain info: [
    {
        "guestId": "255d3011-0665-4b9c-9c9b-dcc12faa00ea",
        "state": 5,
        "attributes": {
            "active": 0,
            "virtWhoType": "libvirt",
            "hypervisorType": "QEMU"
        }
    },
    {
        "guestId": "5ccf097b-c9f9-40af-8a1b-f38811ee4d0c",
        "state": 5,
        "attributes": {
            "active": 0,
            "virtWhoType": "libvirt",
            "hypervisorType": "QEMU"
        }
    },
    {
        "guestId": "e782d10f-00d7-4989-a54f-3d0292f06f63",
        "state": 5,
        "attributes": {
            "active": 0,
            "virtWhoType": "libvirt",
            "hypervisorType": "QEMU"
        }
    }
]
2015-08-26 00:54:46,809 INFO: virt-who guest list update successful
2015-08-26 00:54:46,809 DEBUG: Association for config env/cmdline gathered
2015-08-26 00:54:46,810 DEBUG: virt-who shut down started

Additional info:
Comment 1 Radek Novacek 2015-08-27 10:55:01 EDT
Fixed in virt-who-0.14-6.el7.
Comment 3 gaoshang 2015-08-30 00:23:12 EDT
this bug has been verified on brew virt-who virt-who-0.14-6.el7 and passed, thanks!
Testing steps:
1. run # virt-who -o -d
2. check log in /var/log/rhsm/rhsm.log, "Sending domain info" exist
2015-08-28 06:27:11,965 - entitlement - INFO - >>>Remote Run: virt-who -o -d
2015-08-28 06:27:16,172 - entitlement - INFO - <<<Return Code: 0
2015-08-28 06:27:16,172 - entitlement - INFO - <<<Output:
2015-08-28 06:27:13,860 INFO: No configurations found, using libvirt as backend
2015-08-28 06:27:13,861 INFO: Using configuration "env/cmdline" ("libvirt" mode)
2015-08-28 06:27:13,913 INFO: Using libvirt url: ""
2015-08-28 06:27:13,927 DEBUG: Virtual machine found: 6.7_Server_x86_64: 5e222409-6f47-4196-88f2-bc88e8804ba4
2015-08-28 06:27:13,927 DEBUG: Libvirt domains found: ['5e222409-6f47-4196-88f2-bc88e8804ba4']
2015-08-28 06:27:13,931 DEBUG: Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-08-28 06:27:14,093 INFO: Sending domain info: [
    {
        "guestId": "5e222409-6f47-4196-88f2-bc88e8804ba4", 
        "state": 5, 
        "attributes": {
            "active": 0, 
            "virtWhoType": "libvirt", 
            "hypervisorType": "QEMU"
        }
    }
]
2015-08-28 06:27:15,396 INFO: virt-who guest list update successful
Comment 4 errata-xmlrpc 2015-11-19 06:57:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2370.html

Note You need to log in before you can comment on or make changes to this bug.