Bug 1257076 - DHT-rebalance: rebalance status shows failed when replica pair bricks are brought down in distrep volume while re-name of files going on
Summary: DHT-rebalance: rebalance status shows failed when replica pair bricks are bro...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1237059
Blocks: 1216951 1318196
TreeView+ depends on / blocked
 
Reported: 2015-08-26 08:47 UTC by Susant Kumar Palai
Modified: 2016-06-16 13:33 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1237059
: 1318196 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:33:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-08-26 09:12:48 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

Comment 2 Anand Avati 2015-08-31 07:52:43 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

Comment 3 Anand Avati 2015-08-31 10:33:03 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#3) for review on master by Susant Palai (spalai@redhat.com)

Comment 4 Anand Avati 2015-08-31 11:49:20 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#4) for review on master by Susant Palai (spalai@redhat.com)

Comment 5 Vijay Bellur 2015-10-12 10:06:30 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#5) for review on master by Susant Palai (spalai@redhat.com)

Comment 6 Kaleb KEITHLEY 2015-10-22 17:00:12 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 7 Kaleb KEITHLEY 2015-10-22 17:06:51 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 8 Kaleb KEITHLEY 2015-10-22 17:11:18 UTC
changing version to mainline in order to retire pre-release.

If you know the appropriate, correct version for this bug, please
set it.

Comment 9 Vijay Bellur 2015-10-29 07:17:48 UTC
REVIEW: http://review.gluster.org/12013 (cluster/dht/rebalance: rebalance failure handling) posted (#6) for review on master by Susant Palai (spalai@redhat.com)

Comment 10 Vijay Bellur 2015-10-29 08:30:19 UTC
COMMIT: http://review.gluster.org/12013 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a53c5c8e322e30b865b7c69aa9558474e033c89a
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Aug 26 04:49:29 2015 -0400

    cluster/dht/rebalance: rebalance failure handling
    
    At current state rebalance aborts basically on any failure
    like fix-layout of a directory, readdirp, opendir etc. Unless it is
    not a remove-brick process we can ignore these failures.
    
    Major impact:  Any failure in the gf_defrag_process_dir means there
    are files left unmigrated in the directory.
    
    Fix-layout(setxattr) failure will impact it's child subtree i.e.
    the child subtree will not be rebalanced.
    
    Settle-hash (commit-hash)failure will trigger lookup_everywhere for
    immediate children until the next commit-hash.
    
    Note: Remove-brick opertaion is still sensitive to any kind of failure.
    
    Change-Id: I08ab71909bc832f03cc1517172525376f7aed14a
    BUG: 1257076
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12013
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 11 Niels de Vos 2016-06-16 13:33:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.