Bug 125710 - RFE: Patch: MS CBCP is not supported properly
RFE: Patch: MS CBCP is not supported properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 122582 rcn-isdn FC4Target
  Show dependency treegraph
 
Reported: 2004-06-10 10:06 EDT by Jochen Wiedmann
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.3.26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 09:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Wiedmann 2004-06-10 10:06:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040515 Firefox/0.8

Description of problem:
The Microsoft CBCP protocol is used to dial in to a NT-RAS server.
Currently the initscript ifup-ippp only supports a single CBCP
related parameter

    CBCP=ON

If this is set to true, then the parameter "callback 6" is added
to the command line invoking ipppd.

This is insufficient. While the above setup may be sufficient for
the so-called "Admin managed callback" (didn't try), it cannot be
used for the so-called "User managed callback". The difference is,
that the latter allows the user to specify the phone number, which
is called back. Note, that using CBCP doesn't make very much sense
in the case of the "Admin managed callback", because you typically
pay some money for initiating the callback. (One needs an open
PPP connection to negotiate the callback.) In other words, the
"user managed callback" is the only case, where CBCP actually
makes sense.

User managed callback is supported by the ipppd by simply specifying
the phone number rather than the protocol identifier. In other words,
in my case one needs to replace

    callback 6

with

    callback 07121xxxxx

(my phone number being 07121xxxxxx). To achieve that, I changed
the line

    CBCP=on

to

    CBCP=07121xxxxxx

in /etc/sysconfig/network-scripts/ifcfg-MyIsdnConnection. (Note,
that I also had to edit the parameters MSN and PHONE_IN manually,
because the callback wasn't accepted without, see /var/log/messages.)
I also changed the following line in ifup-ippp:

   [ "$CBCP" = "on" ] && options="$options callback 6"

to

   [ "$CBCP" = "off" ] || options="$options callback $CBCP"

This may not be the best version, but it works for me.


Version-Release number of selected component (if applicable):
initscripts-7.53-1

How reproducible:
Always

Steps to Reproduce:
1. Use the system-network-config to create a proper
/etc/sysconfig/network-scripts/ifcfg-MyIsdnConnection and
note, that a callback doesn't happen.

    

Additional info:
Comment 3 Ngo Than 2004-08-03 09:04:30 EDT
i think the correct fix would be:

   [ "$CBCP" = "on" ] && options="$options callback $PHONE_IN"


could you please try if it works for you? Thanks
Comment 4 Jochen Wiedmann 2004-08-03 10:21:15 EDT
The solution suggested in Comment 3 would possibly work, but I believe
it is based on some misunderstandment, either on my side or on yours.

$PHONE_IN is, AFAIK, the remotes phone number that I am seeing, if the
callback comes in. However, that is not what the "User Managed
Callback" requires: It needs the phone number, that the remote side
has to dial when calling back: My phone number. In other words, if
anything at all, one might try

    [ "$CBCP" = "on" ] && options="$options callback $MSN"

besides the problem, that the MSN will typically be incomplete
(without the area number and country code).

Besides, your suggestion will leave the user the choice between the
"User managed callback" and no CBCP at all: It disables the
possibility of the "Admin managed callback". (Which my solution
does as well.) In other words, the best solution might probably be to
replace

    [ "$CBCP" = "on" ] && options="$options callback 6"

with

    if [ "$CBCP" = "on" ]; then
      # Do nothing, admin managed callback is enabled by default
    elif [ "$CBCP" = "off" ]; then
      # Disable CBCP
      options="$options -callback-cbcp"
    else
      # User managed callback
      options="$options callback $CBCP"
    fi
Comment 5 Ngo Than 2004-08-04 07:17:40 EDT
ok, it's a misunderstandment, your solution seems the best ATM. it
still needs to fix r-c-n to allow user to define the phone number there.
Comment 7 Ngo Than 2004-10-11 18:19:03 EDT
reassign to s-c-n.

Note You need to log in before you can comment on or make changes to this bug.