Bug 1257139 - power: there are some unsupported x86 devices under the output of cmds 'man qemu-kvm'
power: there are some unsupported x86 devices under the output of cmds 'man q...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
ppc64le Unspecified
low Severity unspecified
: rc
: ---
Assigned To: David Gibson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 06:57 EDT by Gu Nini
Modified: 2015-08-30 23:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-30 23:00:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gu Nini 2015-08-26 06:57:06 EDT
Description of problem:
In a ppc64le host, for the output cmd 'man qemu-kvm', it is the same as that in a x86_64 host, i.e. there are some of the removed x86 devices, such as 'isa-serial', 'isa-parallel' and 'ich9-usb-uhci1' etc.

Version-Release number of selected component (if applicable):
Host kernel: 3.10.0-306.0.1.el7.ppc64le
Qemu-kvm-rhev: qemu-kvm-rhev-2.3.0-19.el7.ppc64le

How reproducible:
100%

Steps to Reproduce:
1. Issue cmd 'man qemu-kvm', check the devices and the description there

Actual results:
There are some x86 related devices that are already removed from ppc as bz 1160120 described

Expected results:
No the removed x86 devices any more

Additional info:
The bug is the left issue in bz 1191845
Comment 2 David Gibson 2015-08-30 23:00:46 EDT
The man page for qemu isn't intended to be specific to a particular target.  Not all options will work for all targets - there are already some which won't work for x86, though not nearly as many as for Power.

Note You need to log in before you can comment on or make changes to this bug.