Bug 1257141 - [Backup]: Glusterfind pre attribute '--output-prefix' not working as expected in case of DELETEs
[Backup]: Glusterfind pre attribute '--output-prefix' not working as expected...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterfind (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Saravanakumar
bugs@gluster.org
: Triaged
Depends On: 1244144
Blocks: 1223636 1241385
  Show dependency treegraph
 
Reported: 2015-08-26 07:01 EDT by Saravanakumar
Modified: 2016-04-19 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1244144
Environment:
Last Closed: 2016-02-14 08:14:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-26 07:06:02 EDT
REVIEW: http://review.gluster.org/12016 (tools/glusterfind: Prepend prefix in case of delete) posted (#2) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 2 Anand Avati 2015-08-26 07:09:27 EDT
REVIEW: http://review.gluster.org/12016 (tools/glusterfind: Prepend prefix in case of delete) posted (#3) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 3 Vijay Bellur 2015-11-18 06:28:39 EST
REVIEW: http://review.gluster.org/12016 (tools/glusterfind: Prepend prefix in case of delete) posted (#4) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 4 Vijay Bellur 2015-11-22 23:45:35 EST
REVIEW: http://review.gluster.org/12016 (tools/glusterfind: Prepend prefix in case of delete) posted (#5) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)
Comment 5 Vijay Bellur 2015-11-24 06:36:18 EST
REVIEW: http://review.gluster.org/12016 (tools/glusterfind: Prepend prefix in case of delete) posted (#6) for review on release-3.7 by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 6 Vijay Bellur 2015-11-25 02:20:37 EST
COMMIT: http://review.gluster.org/12016 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit a4852c92d9345c67ebc0eacc724b2fec214e98f7
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Fri Jul 17 15:51:22 2015 +0530

    tools/glusterfind: Prepend prefix in case of delete
    
    In case of delete operation alone, output prefix adding
    was not handled earlier.
    Output prefix is added now.
    
    Change-Id: Ia91444dddbff501b26a864f6185ca4c0aaf4c802
    Reviewed-on: http://review.gluster.org/11712/
    BUG: 1257141
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Reviewed-on: http://review.gluster.org/12016
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 7 Kaushal 2016-04-19 03:46:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.