Bug 1257148 - Evolution cannot contact gnome-keyring
Evolution cannot contact gnome-keyring
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 07:17 EDT by Stephen Gallagher
Modified: 2015-08-31 08:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 08:55:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-08-26 07:17:54 EDT
Description of problem:

I upgraded to Fedora 23 the other day. Since doing so, Evolution has been unable to contact any of my remote data sources (Contacts, calendars) due to being unable to retrieve the saved passwords from the keyring. It reports the following error message: "Failed to obtain an access token for 'Contacts': No credentials found in the keyring"

Version-Release number of selected component (if applicable):
evolution-3.17.90-1.fc23.x86_64
gnome-keyring-3.16.0-2.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start from Fedora 22
2. Connect Evolution to a remote data source (such as Google Calendar)
3. Upgrade to Fedora 23
4. Start Evolution

(There may be simpler repro steps, but this is how it happened for me)

Actual results:
Calendar and contacts are unable to be retrieved and I get the error message above.

Expected results:
All of my data sources should be contacted properly.


Additional info:

My email works, but I suspect that's due to using GSSAPI/Kerberos for authentication rather than password authentication (which I suspect would similarly fail)
Comment 1 Milan Crha 2015-08-27 10:45:28 EDT
Thanks for a bug report. The error says:
> Failed to obtain an access token for 'Contacts':
> No credentials found in the keyring
which means evolution can talk to gnome-keyring, but the password is missing there. It can be something caused by the update. As the account is configured in GOA (GNOME Online Accounts), the password is provided by it, thus, in this case, evolution doesn't talk to the keyring directly, but using the goa-daemon. Could you open gnome-control-center, choose Online Accounts and verify that everything is fine there? The GOA shows exclamation marks for accounts which need attention, like sing in again (OAuth2 tokens can also expire).
Comment 2 Stephen Gallagher 2015-08-31 08:55:40 EDT
You're right; looks like after upgrading, the new version of GOA appears to Google as a different machine, necessitating that I re-supply my OTP.

Note You need to log in before you can comment on or make changes to this bug.