Bug 1257151 - Rename Sun Solaris to just Solaris
Rename Sun Solaris to just Solaris
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libosinfo (Show other bugs)
unspecified
All Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Zeeshan Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 07:30 EDT by Jan Vlug
Modified: 2016-09-19 21:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 07:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Vlug 2015-08-26 07:30:52 EDT
In the New VM window of the Virtual Machine Manager, you can select for the OS type: 'Solaris'. In this case the available versions are named like 'Sun *'.
However Solaris is now owned by Oracle.

I suggest to leave the vendor part (i.e. 'Sun') out of the version name. Replacing it by 'Oracle' could also lead to confusion, because for example certain versions of Solaris 10 were delivered by Sun.
Comment 1 Cole Robinson 2015-08-31 17:02:42 EDT
This is in libosinfo nowadays
Comment 2 Daniel Berrange 2015-09-01 04:54:47 EDT
Note that libosinfo aims to use the operating system name & vendor that was applicable at the time the product was initially released. IOW, any Solaris versions that were released while owned by Sun, should refer to the vendor as Sun, not Oracle. Only versions of Solaris released after Oracle acquisition would be labelled as Oracle.

Whether we should be including 'Sun' in the product name as well though, I'm not sure. We'd have to look again at what the actual formal product name was, and whether it included "Sun".
Comment 3 Jan Vlug 2015-09-01 06:15:21 EDT
As far as I could find:
The first Solaris 10 release was done by Sun.
The first Solaris 11 release was done by Oracle (http://www.serverwatch.com/article.php/3897706)

Whether the vendor name is part of actual formal product name: I think for Oracle Solaris 11 it is part of it: http://www.oracle.com/us/products/servers-storage/solaris/solaris11/overview/index.html

I do not know whether this was also the case for the first Sun Solaris 10 release.
Comment 4 Daniel Berrange 2015-09-01 06:19:21 EDT
Ok, so I'd suggest we fix the name + vendor field for Solaris 11 to refer to oracle, and leave Solaris 10 info unchanged.
Comment 5 Jan Vlug 2015-09-02 03:09:26 EDT
I got the impression that "Sun" was not part of the actual formal product name for the Solaris versions released by Sun and for OpenSolaris:
https://web.archive.org/web/20090216095813/http://www.sun.com/software/solaris/
Comment 6 Daniel Berrange 2015-09-02 04:12:53 EDT
Ah ok, thanks for finding that link in archive.org. We can drop Sun from the product name of old versions too then
Comment 7 Daniel Berrange 2015-09-02 07:30:21 EDT
Fix merged upstream

commit dfd14e6e93ce2a6dd632e531a2591dac031e079c
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Wed Sep 2 09:57:34 2015 +0100

    Fix sun/oracle confusion in solaris metadata


https://git.fedorahosted.org/cgit/libosinfo.git/commit/?id=dfd14e6e93ce2a6dd632e531a2591dac031e079c

Note You need to log in before you can comment on or make changes to this bug.