Bug 1257159 - abrt-cli allows to start reporting not-reportable problems
abrt-cli allows to start reporting not-reportable problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: abrt
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 07:43 EDT by Martin Kyral
Modified: 2017-08-01 14:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: abrt-2.1.11-48.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 14:15:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch 1/3: reportclient: fix verbosity test (961 bytes, patch)
2017-02-14 07:07 EST, Matej Habrnal
no flags Details | Diff
Patch 2/3: tree-wide: introduce 'stop_on_not_reportable' option (10.57 KB, patch)
2017-02-14 07:07 EST, Matej Habrnal
no flags Details | Diff
Patch 3/3: reportclient: honor ABRT_VERBOSE (3.65 KB, patch)
2017-02-14 07:07 EST, Matej Habrnal
no flags Details | Diff
Patch 1/5: lib: stop printing out a debug message 'adding: ' (889 bytes, patch)
2017-02-14 07:44 EST, Matej Habrnal
no flags Details | Diff
Patch 2/5: cli: don't start reporting of not-reportable problems (1.41 KB, patch)
2017-02-14 07:44 EST, Matej Habrnal
no flags Details | Diff
Patch 3/5: cli: introduce unsafe reporting for not-reporable problems (8.93 KB, patch)
2017-02-14 07:44 EST, Matej Habrnal
no flags Details | Diff
Patch 4/5: cli: configure libreport to ignore not-reportable (1.52 KB, patch)
2017-02-14 07:44 EST, Matej Habrnal
no flags Details | Diff
Patch 5/5: cli: print out the not-reportable reason (1.42 KB, patch)
2017-02-14 07:44 EST, Matej Habrnal
no flags Details | Diff

  None (edit)
Description Martin Kyral 2015-08-26 07:43:49 EDT
Description of problem:
The upstream cli-sanity test fails in the not-reportable phase as follows:

:: [  BEGIN   ] :: Running 'touch /var/spool/abrt/ccpp-2015-08-21-19:08:55-7279/not-reportable'
:: [   PASS   ] :: Command 'touch /var/spool/abrt/ccpp-2015-08-21-19:08:55-7279/not-reportable' (Expected 0, got 0)
:: [  BEGIN   ] :: Running 'abrt-cli report /var/spool/abrt/ccpp-2015-08-21-19:08:55-7279 2>&1 | tee abrt-cli-report-not-reportable.log'
Error: no processing is specified for event 'report-cli'
:: [   PASS   ] :: Command 'abrt-cli report /var/spool/abrt/ccpp-2015-08-21-19:08:55-7279 2>&1 | tee abrt-cli-report-not-reportable.log' (Expected 0, got 0)
:: [   FAIL   ] :: File 'abrt-cli-report-not-reportable.log' should contain 'Problem '/var/spool/abrt/ccpp-2015-08-21-19:08:55-7279' cannot be reported' 

because abrt-cli report does not print the '... cannot be reported' message out.


Version-Release number of selected component (if applicable):
abrt-2.1.11-31.el7

How reproducible:
Always

Steps to Reproduce:
1. run the upstream test or repeat the reproducing steps (see above)
2.
3.
Comment 2 Matej Habrnal 2017-01-26 07:58:17 EST
Opened upstream pull requests:
https://github.com/abrt/abrt/pull/1221
https://github.com/abrt/libreport/pull/475
Comment 4 Matej Habrnal 2017-02-14 07:07:07 EST
Created attachment 1250191 [details]
Patch 1/3: reportclient: fix verbosity test
Comment 5 Matej Habrnal 2017-02-14 07:07:10 EST
Created attachment 1250192 [details]
Patch 2/3: tree-wide: introduce 'stop_on_not_reportable' option
Comment 6 Matej Habrnal 2017-02-14 07:07:13 EST
Created attachment 1250193 [details]
Patch 3/3: reportclient: honor ABRT_VERBOSE
Comment 7 Matej Habrnal 2017-02-14 07:44:46 EST
Created attachment 1250219 [details]
Patch 1/5: lib: stop printing out a debug message 'adding: '
Comment 8 Matej Habrnal 2017-02-14 07:44:49 EST
Created attachment 1250220 [details]
Patch 2/5: cli: don't start reporting of not-reportable problems
Comment 9 Matej Habrnal 2017-02-14 07:44:52 EST
Created attachment 1250221 [details]
Patch 3/5: cli: introduce unsafe reporting for not-reporable problems
Comment 10 Matej Habrnal 2017-02-14 07:44:55 EST
Created attachment 1250222 [details]
Patch 4/5: cli: configure libreport to ignore not-reportable
Comment 11 Matej Habrnal 2017-02-14 07:44:57 EST
Created attachment 1250223 [details]
Patch 5/5: cli: print out the not-reportable reason
Comment 13 errata-xmlrpc 2017-08-01 14:15:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1927

Note You need to log in before you can comment on or make changes to this bug.