Bug 1257181 - [abrt] mock: util.py:361:logOutput:OSError: [Errno 5] Input/output error
[abrt] mock: util.py:361:logOutput:OSError: [Errno 5] Input/output error
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:653596d7a59e16f98df644cfdd0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 08:26 EDT by Jonathan Wakely
Modified: 2015-09-04 03:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-04 03:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.04 KB, text/plain)
2015-08-26 08:26 EDT, Jonathan Wakely
no flags Details
File: environ (182 bytes, text/plain)
2015-08-26 08:26 EDT, Jonathan Wakely
no flags Details

  None (edit)
Description Jonathan Wakely 2015-08-26 08:26:49 EDT
Version-Release number of selected component:
mock-1.2.12-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/sbin/mock -r fedora-rawhide-x86_64 --rebuild boost-1.59.0-1.fc24.src.rpm
executable:     /usr/sbin/mock
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
#1 logOutput in /usr/lib/python3.4/site-packages/mockbuild/util.py:361
#2 do in /usr/lib/python3.4/site-packages/mockbuild/util.py:455
#3 trace in /usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py:84
#4 _selinuxDoYum in /usr/lib/python3.4/site-packages/mockbuild/plugins/selinux.py:104
#5 trace in /usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py:84
#6 execute in /usr/lib/python3.4/site-packages/mockbuild/package_manager.py:85
#7 trace in /usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py:84
#8 builddep in /usr/lib/python3.4/site-packages/mockbuild/package_manager.py:105
#9 trace in /usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py:84
#10 builddep in /usr/lib/python3.4/site-packages/mockbuild/package_manager.py:255
Comment 1 Jonathan Wakely 2015-08-26 08:26:53 EDT
Created attachment 1067236 [details]
File: backtrace
Comment 2 Jonathan Wakely 2015-08-26 08:26:54 EDT
Created attachment 1067237 [details]
File: environ
Comment 3 Miroslav Suchý 2015-08-26 10:31:49 EDT
Is there way to reproduce it?

Only way I know it *may* reproduce is to run mock as subprocess, then kill the parent process and then the terminal. Then the child process may produce such traceback.
However it is so obscure to me. How this happened to you?
Comment 4 Jonathan Wakely 2015-08-26 10:37:20 EDT
Ah, I think this one may have happened when I got an X server crash, so the parent and terminal (a konsole window) and everything else would have been killed.

So maybe just close this.
Comment 5 Miroslav Suchý 2015-09-04 03:09:18 EDT
It would be quite hard do fix mock to not produce error in such case (and distinguish it from cases where it is actually error). Since it even happen in some special timing... IMO not worth the work and I would like to focus on other bugs, which are real blockers.

Note You need to log in before you can comment on or make changes to this bug.