Bug 1257185 - Error after adding Virtual Machines to Statistics Daily domain in ad-hoc reports
Error after adding Virtual Machines to Statistics Daily domain in ad-hoc reports
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.5.4
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.6.0
Assigned To: Shirly Radco
Petr Matyáš
reports
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 08:41 EDT by Petr Matyáš
Modified: 2016-02-10 15:13 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1234821
Environment:
Last Closed: 2015-10-14 10:21:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Reports
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jasper log (1.29 MB, text/plain)
2015-08-26 08:41 EDT, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2015-08-26 08:41:08 EDT
Created attachment 1067238 [details]
jasper log

+++ This bug was initially created as a clone of Bug #1234821 +++

Description of problem:
Error after trying to add Virtual Machines field to either rows or columns in ad-hoc reports.

Version-Release number of selected component (if applicable):
3.6

How reproducible:
always on my setup

Steps to Reproduce:
1. open reports portal
2. create new ad-hoc report from statistics daily domain
3. try to add virtual machine field to either row or column

Actual results:
error

Expected results:
no error

Additional info:
ovirt-engine-3.6.0-0.0.master.20150622174128.gitd7d1d87.el6.noarch
ovirt-engine-dwh-3.6.0-0.0.master.20150617151108.20150617150804.gitfccbb7a.el6.noarch
rhevm-reports-3.6.0-0.0.master.20150602141841.el6ev.noarch
jasperreports-server-pro-6.0.1-1.el6ev.noarch

--- Additional comment from Shirly Radco on 2015-06-24 10:49:10 CEST ---

For Statistics Daily and Hourly domains, If I add the Virtual Machines fields in parts I can add all of them with no error.
If I try adding all of them at the same time I get an error:

"An error occurred while performing the previous request."

And after that I get this error if I try adding any field. The ad hoc view is corrupted.

This seems like a Jasper server bug. I'm guessing due to the amount of fields in this section.

Yaniv, What do you think?

--- Additional comment from Shirly Radco on 2015-06-24 13:22:25 CEST ---

After checking this there is a problem adding fields from  "Running Host Configuration" together with fields from "Users' Usage".

--- Additional comment from Yaniv Dary on 2015-06-29 09:29:23 CEST ---

It's cased by:
"public_v3_6_statistics_vms_users_usage_hourly"."currently_running_on_host" = "running_on_host"."history_id"

currently_running_on_host is UUID and history_id is int.
The join is wrong, needs to be current_host_configuration_version.
Comment 1 Yaniv Lavi 2015-10-11 13:37:26 EDT
why did you clone this bug?
Comment 2 Petr Matyáš 2015-10-12 02:34:56 EDT
Because it happens on 3.5 as well as 3.6
Comment 3 Yaniv Lavi 2015-10-14 10:21:42 EDT
We won't fix this unless customer requests this

Note You need to log in before you can comment on or make changes to this bug.