Bug 1257201 - xulrunner fails to build because of undefined reference
xulrunner fails to build because of undefined reference
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
22
ppc Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2015-08-26 09:17 EDT by Rafael Fonseca
Modified: 2016-02-23 06:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 06:09:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Fonseca 2015-08-26 09:17:39 EDT
Description of problem: xulrunner fails to build on ppc64 and ppc64le with the following error:

../../gfx/skia/Unified_cpp_gfx_skia19.o: In function `SkDiscardablePixelRef::onNewLockPixels(SkPixelRef::LockRec*)':
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/gfx/skia/trunk/src/lazy/SkDiscardablePixelRef.cpp:56: undefined reference to `SkDiscardableMemory::Create(unsigned long)'
/usr/bin/ld: libxul.so: hidden symbol `_ZN19SkDiscardableMemory6CreateEm' isn't defined
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/config/rules.mk:815: recipe for target 'libxul.so' failed
make[5]: Leaving directory '/builddir/build/BUILD/xulrunner-40.0/mozilla-release/objdir/toolkit/library'
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/config/recurse.mk:70: recipe for target 'toolkit/library/target' failed
make[4]: Leaving directory '/builddir/build/BUILD/xulrunner-40.0/mozilla-release/objdir'
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/config/recurse.mk:32: recipe for target 'compile' failed
make[3]: Leaving directory '/builddir/build/BUILD/xulrunner-40.0/mozilla-release/objdir'
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/config/rules.mk:538: recipe for target 'default' failed
make[2]: Leaving directory '/builddir/build/BUILD/xulrunner-40.0/mozilla-release/objdir'
/builddir/build/BUILD/xulrunner-40.0/mozilla-release/client.mk:400: recipe for target 'realbuild' failed
make[1]: Leaving directory '/builddir/build/BUILD/xulrunner-40.0/mozilla-release'
client.mk:171: recipe for target 'build' failed
RPM build errors:


Version-Release number of selected component (if applicable): 40.0-1


How reproducible: ppc-koji build xulrunner


Additional info: It looks like the same error also happens on rawhide in version 39.0-3.
Comment 1 Martin Stransky 2015-09-02 16:08:13 EDT
Should be fixed by xulrunner-40.0-2.
Comment 2 Rafael Fonseca 2015-09-03 07:33:36 EDT
It builds now in a local build. Thank you.

Note You need to log in before you can comment on or make changes to this bug.