Bug 1257212 - various RHEL7 channel maps to product certs are missing in subscription-manager-migration-data
various RHEL7 channel maps to product certs are missing in subscription-manag...
Status: CLOSED DUPLICATE of bug 1241221
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 09:59 EDT by John Sefler
Modified: 2015-09-18 10:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 11:11:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-08-26 09:59:14 EDT
Description of problem:
The comments following in this bugs list RHEL7 channels that were detected from an automated test suite that is complaining about RHN channels that are currently available to a RHEL7 system registered to a Satellite5 server but are not accounted for in the subscription-manager-migration-data package that contains a list of classic channels to product certificate maps....

NEEDINFO from release engineering if the lack of mappings is expected or if the upstream product-certs.json file needs to be regenerated and fed into the script that generates subscription-manager-migration-data.
The upstream mappings are provided by http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/tree/cdn/product-certs.json


RHN Classic channel '<SUBSTITUTE FROM LISTED COMMENTS BELOW>' is accounted for in subscription-manager-migration-data file '/usr/share/rhsm/product/RHEL-7/channel-cert-mapping.txt'. expected:<true> but was:<false>


Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.22-1.el7.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-7 ~]# grep <SUBSTITUTE CHANNEL FROM LISTED COMMENTS BELOW>: /usr/share/rhsm/product/RHEL-7/channel-cert-mapping.txt


Actual results:
  no hit

Expected results:
  a map from the named channel to a product certificate

Additional info:
Comment 1 John Sefler 2015-08-26 10:03:10 EDT
rhel-x86_64-server-hts-7-debuginfo
rhel-x86_64-server-hts-7-beta
rhel-x86_64-server-7-beta-debuginfo
rhel-x86_64-server-7-beta
rhel-x86_64-server-ha-7-beta-debuginfo
rhel-x86_64-server-ha-7-beta
rhel-x86_64-server-optional-7-beta-debuginfo
rhel-x86_64-server-optional-7-beta
rhel-x86_64-server-rs-7-beta-debuginfo
rhel-x86_64-server-rs-7-beta
rhel-x86_64-server-supplementary-7-beta-debuginfo
rhel-x86_64-server-supplementary-7-beta
rhel-x86_64-server-v2vwin-7-beta-debuginfo
rhel-x86_64-server-v2vwin-7-beta
Comment 2 John Sefler 2015-08-31 18:10:56 EDT
rhel-ppc64-server-7-beta
rhel-ppc64-server-7-beta-debuginfo
rhel-ppc64-server-hts-7-beta
rhel-ppc64-server-hts-7-debuginfo
rhel-ppc64-server-optional-7-beta
rhel-ppc64-server-optional-7-beta-debuginfo
rhel-ppc64-server-supplementary-7-beta
rhel-ppc64-server-supplementary-7-beta-debuginfo
Comment 3 John Sefler 2015-08-31 18:15:27 EDT
rhel-x86_64-client-7-beta
rhel-x86_64-client-7-beta-debuginfo
rhel-x86_64-client-optional-7-beta
rhel-x86_64-client-optional-7-beta-debuginfo
rhel-x86_64-client-supplementary-7-beta
rhel-x86_64-client-supplementary-7-beta-debuginfo
Comment 4 John Sefler 2015-08-31 18:18:17 EDT
rhel-x86_64-hpc-node-7-beta
rhel-x86_64-hpc-node-7-beta-debuginfo
rhel-x86_64-hpc-node-optional-7-beta
rhel-x86_64-hpc-node-optional-7-beta-debuginfo
rhel-x86_64-hpc-node-supplementary-7-beta
rhel-x86_64-hpc-node-supplementary-7-beta-debuginfo
Comment 5 John Sefler 2015-08-31 18:21:05 EDT
rhel-x86_64-workstation-7-beta
rhel-x86_64-workstation-7-beta-debuginfo
rhel-x86_64-workstation-optional-7-beta
rhel-x86_64-workstation-optional-7-beta-debuginfo
rhel-x86_64-workstation-supplementary-7-beta
rhel-x86_64-workstation-supplementary-7-beta-debuginfo
Comment 6 Andrew Thomas 2015-09-04 13:01:02 EDT
Updated mappings file with these channels.

Note: Any hts-7-beta and v2v-7-beta channels will be ignored as they do not have any beta content. Please ignore in the future.
Comment 7 John Sefler 2015-09-04 16:10:27 EDT
rhel-s390x-server-7-beta
rhel-s390x-server-7-beta-debuginfo
rhel-s390x-server-hts-7-beta
rhel-s390x-server-hts-7-debuginfo
rhel-s390x-server-optional-7-beta
rhel-s390x-server-optional-7-beta-debuginfo
rhel-s390x-server-supplementary-7-beta
rhel-s390x-server-supplementary-7-beta-debuginfo
Comment 8 Andrew Thomas 2015-09-14 11:35:58 EDT
Added to product-certs.json
Comment 9 John Sefler 2015-09-15 14:02:30 EDT
These four channels exist in upstream product-certs.json
They do not exist in subscription-manager-migration-data-2.0.23-1.el7.noarch


rhel-x86_64-client-7-thirdparty-oracle-java
rhel-x86_64-hpc-node-7-thirdparty-oracle-java
rhel-x86_64-server-7-thirdparty-oracle-java
rhel-x86_64-workstation-7-thirdparty-oracle-java
Comment 10 John Sefler 2015-09-15 14:23:40 EDT
(In reply to John Sefler from comment #9)
> These four channels exist in upstream product-certs.json

My mistake...  The four channels in comment 9 are *not* found in upstream product-certs.json.  NEEDINFO from anthomas.
Comment 11 Andrew Thomas 2015-09-16 14:08:46 EDT
Certificates were not created for 7.2 and these channels were therefore dropped when the update from 7.1 to 7.2 occurred. I have created the certs and regenerated the file.
Comment 12 Alex Wood 2015-09-17 11:02:31 EDT
In subscription-manager-migration-data-2.0.24-1
Comment 13 Alex Wood 2015-09-17 11:11:19 EDT

*** This bug has been marked as a duplicate of bug 1241221 ***

Note You need to log in before you can comment on or make changes to this bug.